Package Details: nextcloud-desktop-git 2.5.3.rc1-1

Git Clone URL: https://aur.archlinux.org/nextcloud-desktop-git.git (read-only)
Package Base: nextcloud-desktop-git
Description: Nextcloud desktop client
Upstream URL: https://nextcloud.com/
Licenses: GPL2
Conflicts: mirall-git, nextcloud-client, nextcloud-client-git, nextcloud-desktop, owncloud-client, owncloud-client-git, owncloud-client-ngs
Provides: nextcloud-client
Submitter: tyzoid
Maintainer: tyzoid
Last Packager: tyzoid
Votes: 6
Popularity: 0.056886
First Submitted: 2018-06-17 16:30
Last Updated: 2019-05-15 21:18

Latest Comments

1 2 Next › Last »

tyzoid commented on 2019-05-15 21:52

I've updated the PKGBUILD to fix the /lib64 path conflict.

To those saying there are build errors, can you please provide a build log, as well as system config info? (what processor arch, whether multilib is enabled, etc).

Also - please don't just flag this package out of date just because the version number is off - it's a -git package, so it'll always build the latest. If there's a problem where it builds something other than latest, then let me know.

elzaphod commented on 2019-04-09 08:49

There is an error when compiling which was solved long time ago: https://bugs.archlinux.org/task/61033 Also the 'make doc-man' in the PKGBUILD is broken. Thanks!

averelld commented on 2018-12-08 20:25

And then you also need -DBUILD_SHELL_INTEGRATION_DOLPHIN=OFF because the dolphin lib has a hardcoded lib64 path.

Phlogiston commented on 2018-11-26 19:47

The DCMAKE_INSTALL_LIBDIR=lib was removed in a previous commit. It should be re-added, as it does solve the conflicting file issue.

gwaaf commented on 2018-10-27 10:45

The error "Error: Could not perform the operation (conflicting files) nextcloud-desktop-git: /usr/lib64 exists in the file system" can be fixed by adding "-DCMAKE_INSTALL_LIBDIR=lib" to the cmake options in the PKGBUILD.

Anonymous comment on 2018-10-22 07:44

I can build this, but i can't install it. I got this errors: Error: Could not perform the operation (conflicting files) nextcloud-desktop-git: / usr / lib64 exists in the file system (belongs to filesystem) Errors have occurred, no packages have been updated.

tyzoid commented on 2018-10-21 21:03

@michaldybczak: I built this because the nextcloud-client was outdated and wasn't working properly - things may have changed since then, but I'll need to investigate why and send bugs upstream as needed. I agree something seems weird, since it should build the latest version out of git each time.

@ReedWade: I'm still maintaining the package - it continues to work fine on my laptop, but seems broken on my desktop I'm currently investigating.

@Celti - thanks for the info. I definitely will be adding that.

michaldybczak commented on 2018-10-17 07:26

This package is broken. First: it seems to work but does not sync, second: it is always shown as outdated in Octopi, do I update it and immediately is marked as outdated. This never happened to any AUR package, even those marked as outdated. It's as if it was constantly detecting new version but couldn't install it, so something in PKGBUILD is wrong. I installed then nextcloud-client and it works out of the box, unlike this version.

ReedWade commented on 2018-09-28 15:07

What should we do if this packages is not maintained anymore ?

Celti commented on 2018-09-21 22:28

Git packages must have a makedepend on git. This will not build in a container without it.