Package Details: nextcloud-client-git-nokde 66.8aade24-2

Git Clone URL: https://aur.archlinux.org/nextcloud-client-git-nokde.git (read-only, click to copy)
Package Base: nextcloud-client-git-nokde
Description: Nextcloud desktop client (no kio/dolphin support, with systemd user session service)
Upstream URL: https://nextcloud.com/
Licenses: GPL2
Conflicts: nextcloud-client, nextcloud-client-git
Provides: mirall, mirall-git, nextcloud-client, nextcloud-client-git
Submitter: coderobe
Maintainer: None
Last Packager: coderobe
Votes: 4
Popularity: 0.000001
First Submitted: 2016-11-19 15:42
Last Updated: 2016-11-24 20:00

Latest Comments

hugegameartgd commented on 2020-02-11 15:37

Please change source to https://github.com/nextcloud/desktop.git master as the former client_theming git repo has been archived by the owner, something like:

diff --git a/PKGBUILD b/PKGBUILD
index 3ff0fe0..0088ba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@

 _name='nextcloud-client'
 pkgname="${_name}-git-nokde"
-pkgver=66.8aade24
-pkgrel=2
+pkgver=14127.8f2e853ec
+pkgrel=1
 pkgdesc='Nextcloud desktop client (no kio/dolphin support, with systemd user session service)'
 arch=('i686' 'x86_64')
 url='https://nextcloud.com/'
@@ -14,7 +14,7 @@ makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'cmake')
 optdepends=('python2-nautilus: integration with Nautilus' 'nemo-python: integration with Nemo')
 conflicts=('nextcloud-client' 'nextcloud-client-git')
 provides=('mirall' 'mirall-git' 'nextcloud-client' 'nextcloud-client-git')
-source=("${_name}::git+https://github.com/nextcloud/client_theming.git" "${_name}.service")
+source=("${_name}::git+https://github.com/nextcloud/desktop.git" "${_name}.service")
 sha256sums=('SKIP' '590d44296e12dd4389dc2bbd100b1f680f5ef6dee381469748525fd34af32009')
 backup=('etc/Nextcloud/sync-exclude.lst')

@@ -36,7 +36,7 @@ prepare() {
 build() {
   cd "${srcdir}/${_name}/build-linux"

-  cmake -D OEM_THEME_DIR=${srcdir}/${_name}/nextcloudtheme ../client \
+  cmake -D OEM_THEME_DIR=${srcdir}/${_name}/nextcloudtheme ../ \
         -DCMAKE_INSTALL_PREFIX=/usr \
         -DCMAKE_INSTALL_LIBDIR=lib \
         -DCMAKE_BUILD_TYPE=Release \
@@ -46,7 +46,7 @@ build() {
 }

 check() {
-  sed -Ei 's|Icon(\[.*\])?=nextcloud|Icon\1=Nextcloud|g' "${srcdir}/${_name}/build-linux/src/gui/nextcloud.desktop"
+  sed -Ei 's|Icon(\[.*\])?=nextcloud|Icon\1=Nextcloud|g' "${srcdir}/${_name}/build-linux/src/gui/com.nextcloud.desktopclient.nextcloud.desktop"
 }

 package() {

ngoonee commented on 2018-04-05 12:34

Systemd service should ideally be similar to the dropbox@.service file, such that it can be started per user but enabled by root, but more importantly that it depends on network.target so it won't be on if there's no network.

coderobe commented on 2017-04-10 21:29

polylux: This seems to be an error on your end, the package still compiles fine for me.

polylux commented on 2017-04-10 11:55

Hey coderobe,

current snapshot seems to fail building. During linkage of nextcloudcmd, libocsync complains about a missing reference to sqlite3_threadsafe. This is the error line:

[ 39%] Linking CXX executable ../../bin/nextcloudcmd
../../csync/src/libocsync.so.2.3.1: undefined reference to `sqlite3_threadsafe'

Bit in a rush atm sorry to not be able to provide a lead.

coderobe commented on 2016-11-24 20:00

i fixed the broken sha256sum of nextcloud-client.service

chrisb commented on 2016-11-24 15:34

I am getting the following:

==> Validating source files with sha256sums...
nextcloud-client ... Skipped
nextcloud-client.service ... FAILED
==> ERROR: One or more files did not pass the validity check!