Package Details: newsflash 1.0.2-1

Git Clone URL: https://aur.archlinux.org/newsflash.git (read-only, click to copy)
Package Base: newsflash
Description: The spiritual successor to FeedReader
Upstream URL: https://gitlab.com/news-flash/news_flash_gtk
Licenses: GPL3
Conflicts: newsflash-git
Submitter: Stunkymonkey
Maintainer: Stunkymonkey
Last Packager: Stunkymonkey
Votes: 4
Popularity: 2.09
First Submitted: 2020-05-16 09:56
Last Updated: 2020-08-03 10:16

Latest Comments

1 2 Next › Last »

pauper commented on 2020-07-14 21:45

@Stunkymonkey Not sure I follow what that has to do with downloading straight from the release urls instead of git commits. But if it is necessary, when this is working again git will have to be in the make depends and libhandy moved to depends like with the newsflash-git package.

Tio commented on 2020-07-12 21:27

Error:

    Updating crates.io index
    Updating git repository `http://gitlab.com/news-flash/news_flash_base.git`
error: failed to get `news-flash` as a dependency of package `news_flash_gtk v0.0.0 (/var/tmp/pamac-build-tio/newsflash/src/news_flash_gtk)`

Caused by:
  failed to load source for dependency `news-flash`

Caused by:
  Unable to update http://gitlab.com/news-flash/news_flash_base.git?branch=1-0-0-rc-1

Caused by:
  failed to find branch `1-0-0-rc-1`

Caused by:
  cannot locate local branch '1-0-0-rc-1'; class=Reference (4); code=NotFound (-3)
[2/3] Generating com.gitlab.newsflash.appdata.xml_data_merge with a custom command
FAILED: src/com.gitlab.newsflash 
/bin/bash /var/tmp/pamac-build-tio/newsflash/src/news_flash_gtk/build-aux/cargo.sh .. src/com.gitlab.newsflash /var/tmp/pamac-build-tio/newsflash/src/news_flash_gtk/_build ''
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

Stunkymonkey commented on 2020-06-30 11:15

@pauper the problem is the dependency news_flash which is defined here: https://gitlab.com/news-flash/news_flash_gtk/-/blob/f69f2bbafafecb4e0a4b9facf30f510880012c8a/Cargo.toml#L37 . This tag is no longer valid, and therefore can not be used.

pauper commented on 2020-06-29 15:00

Can't this be sourced straight from the releases without git? ie: https://gitlab.com/news-flash/news_flash_gtk/-/releases

issue_no1 commented on 2020-06-22 13:41

By build failed:

...
Found ninja-1.10.0 at /usr/bin/ninja
ninja: Entering directory `_build'
[0/3] Generating cargo-build with a custom command
+ export OUTPUT=src/com.gitlab.newsflash
+ OUTPUT=src/com.gitlab.newsflash
+ export CARGO_TARGET_DIR=/var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/_build/target
+ CARGO_TARGET_DIR=/var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/_build/target
+ export CARGO_HOME=/var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/_build/target/cargo-home
+ CARGO_HOME=/var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/_build/target/cargo-home
+ export PROFILE=
+ PROFILE=
+ TARGET=debug
+ ARGS=()
+ test '' '!=' Devel
+ echo 'RELEASE MODE'
RELEASE MODE
+ ARGS+=('--release')
+ TARGET=release
+ test -d vendor
+ cargo build --release --manifest-path=../Cargo.toml
    Updating crates.io index
    Updating git repository `http://gitlab.com/news-flash/news_flash_base.git`
error: failed to get `news-flash` as a dependency of package `news_flash_gtk v0.0.0 (/var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk)`

Caused by:
  failed to load source for dependency `news-flash`

Caused by:
  Unable to update http://gitlab.com/news-flash/news_flash_base.git?branch=1-0-0-rc-1

Caused by:
  failed to find branch `1-0-0-rc-1`

Caused by:
  cannot locate local branch '1-0-0-rc-1'; class=Reference (4); code=NotFound (-3)
[2/3] Generating com.gitlab.newsflash.appdata.xml_data_merge with a custom command
FAILED: src/com.gitlab.newsflash 
/bin/bash /var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/build-aux/cargo.sh .. src/com.gitlab.newsflash /var/tmp/pamac-build-mes/newsflash/src/news_flash_gtk/_build ''
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

Stunkymonkey commented on 2020-06-08 12:13

@rility if you want to use flatpak, then do not use AUR. Simply your choice.

rility commented on 2020-06-08 04:57

@Stunkymonkey I have mentioned this to Jan and he believed the only proper distribution method necessary is flatpak, so I think this is the better channel to address this.

Stunkymonkey commented on 2020-06-07 19:45

@rility please report feature requests upstream at https://gitlab.com/news-flash/news_flash

rility commented on 2020-06-07 14:56

Is there any way we can ship a version with mercury parser support(and feedly)?

Stunkymonkey commented on 2020-05-26 21:42

@azmeuk this is an upstream issue. the developer removed the "1-0-0-rc-1"-branch on news_flash. and published the code on https://crates.io/crates/news-flash. This should get resolved with the next version.