Package Details: newrelic-infra 1.16.3-1

Git Clone URL: https://aur.archlinux.org/newrelic-infra.git (read-only, click to copy)
Package Base: newrelic-infra
Description: None
Upstream URL: https://github.com/newrelic/infrastructure-agent
Licenses: Apache
Submitter: ioquatix
Maintainer: ioquatix (conws, roobre)
Last Packager: roobre
Votes: 4
Popularity: 0.82
First Submitted: 2017-03-10 01:00
Last Updated: 2021-04-20 12:08

Latest Comments

ioquatix commented on 2021-03-01 01:18

@roobre I've added you as a co-maintainer.

roobre commented on 2021-02-23 12:50

Hey @ioquatix

I'm pasting a patch to bump to the latest release at the time of witing (1.15.2).

If you'd like some helm maintaining this, I currently work at New Relic and I'd be happy to step-up and lend you a hand with it. Just to clarify, I'd be doing this on my free time and it is not in New Relic plans to officially support this package. However I'll do my best to keep it updated and working as long as I have some spare time for it :)

Please tell me what you think.

Patch follows:

diff --git a/PKGBUILD b/PKGBUILD
index 8ad67e4..b1d2459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@

 pkgname=newrelic-infra
-pkgver=1.11.26
+pkgver=1.15.2
 pkgrel=1
 license=('custom')
 arch=('x86_64')
 depends=('curl')
 url=https://download.newrelic.com/infrastructure_agent/linux/apt/pool/main/n/newrelic-infra
 source=($url/newrelic-infra_systemd_${pkgver}_systemd_amd64.deb)
-sha256sums=('6123dcc1c206db060675feecc978662441347c6ad697bf2b56d5cf2f244ca321')
+sha256sums=('5051958c7df07c4425649440694b5ebece7a33b48f01b8c238f3b4708cbf8f00')

 package() {
        tar xvf "${srcdir}/data.tar.gz"
-
+       rm -r "${srcdir}/var/run"
        cp -Ra "${srcdir}/etc" "${pkgdir}"
        cp -Ra "${srcdir}/usr" "${pkgdir}"
        cp -Ra "${srcdir}/var" "${pkgdir}"

ioquatix commented on 2020-05-02 14:35

I've updated this to 1.11.26. However, I'm no longer using this package, so if you want to become a co-maintainer, please let me know.

ioquatix commented on 2017-07-29 11:33

@somekool, thanks for your kind words. I've updated the package to 726. Thanks for your patience.

somekool commented on 2017-07-25 13:47

yes, both releases works
336 and 724 even 726, I see reporting on newrelic

thanks @ioquatix for making this available to ArchLinux

ioquatix commented on 2017-07-25 06:17

@somekool, so should we update?

somekool commented on 2017-07-24 15:02

error logs will display a bunch of deprecation warning/errors.
mostly about IPV6, but reporting works anyway.. I can see my stats in newrelic.

I posted the details on their technical community

https://discuss.newrelic.com/t/newrelic-infra-on-ubuntu-17-04/50752

somekool commented on 2017-07-24 14:36

release 1.0.724 download and installs fine, I've simply update the number in the PKGBUILD, and SKIP the sha256