Package Details: netbeans-javase 8.2-1

Git Clone URL: https://aur.archlinux.org/netbeans-javase.git (read-only, click to copy)
Package Base: netbeans-javase
Description: Oracle's Java (SE) IDE
Upstream URL: http://netbeans.org
Licenses: CDDL
Conflicts: netbeans
Provides: netbeans
Submitter: Xavion
Maintainer: Xavion
Last Packager: Xavion
Votes: 7
Popularity: 0.011606
First Submitted: 2011-01-14 00:51
Last Updated: 2016-11-02 20:03

Dependencies (5)

Required by (2)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Xavion commented on 2011-04-26 23:02

Thanks for the information; I've updated the PKGBUILD.

kullfar commented on 2011-04-26 05:41

# sha1sum netbeans-7.0-201104080000-ml-javase.zip

a2c1ffc7aaf42207b2bcede605eb74637a44fa8c netbeans-7.0-201104080000-ml-javase.zip


As for scripting - I was need no changes. Nor anyone in http://projects.archlinux.org/svntogit/community.git/tree/netbeans/trunk/ as I can see.

Xavion commented on 2011-04-26 00:15

I'm vacationing interstate until early May. I won't be able to download the new 125 MiB archive before then. In the meantime, if someone can post its SHA-1 sum here, I'll update the PKGBUILD. Also, let me know if any scripting changes are necessary.

kullfar commented on 2011-04-25 06:37

7.0 is here ;-)

Xavion commented on 2011-04-19 23:43

Thanks for the suggestion; I've updated the PKGBUILD.

kullfar commented on 2011-04-18 20:08

have checked on another PC (where I had successful build before). almost the same

"/usr/bin/strip: Unable to recognise the format of the input file `./usr/share/netbeans/ide/bin/nativeexecution/SunOS-sparc_64/pty'"


ps.I have 64 bit on both PCs.

kullfar commented on 2011-04-18 13:26

seems like pacman new version brings that.
see https://aur.archlinux.org/packages.php?ID=47593

Updated the PKGBUILD to skip the strip operation (only needed for C/C++ binaries), see the additional line:
options=('!strip')

After the latest pacman update (to version 3.5.1), makepkg seems to more strictly enforce some rules.

kullfar commented on 2011-04-18 12:49

seems like pacman new version brings that.
see https://aur.archlinux.org/packages.php?ID=47593

Updated the PKGBUILD to skip the strip operation (only needed for C/C++ binaries), see the additional line:
options=('!strip')

After the latest pacman update (to version 3.5.1), makepkg seems to more strictly enforce some rules.

kullfar commented on 2011-04-18 12:42

had such error while "makepkg -c"

-> Stripping unneeded symbols from binaries and libraries...
/usr/bin/strip: Unable to recognise the format of the input file `./usr/share/netbeans/profiler/lib/deployed/jdk15/solaris-sparc/libprofilerinterface.so'

kullfar commented on 2011-04-18 12:38

had such error while "makepkg -c"

-> Stripping unneeded symbols from binaries and libraries...
/usr/bin/strip: Unable to recognise the format of the input file `./usr/share/netbeans/profiler/lib/deployed/jdk15/solaris-sparc/libprofilerinterface.so'