Package Details: neovim-nightly 2:0.5.0+20201026-1

Git Clone URL: https://aur.archlinux.org/neovim-nightly.git (read-only, click to copy)
Package Base: neovim-nightly
Description: Fork of Vim aiming to improve user experience, plugins, and GUIs - Nightly Builds
Upstream URL: https://neovim.io
Keywords: neovim nightly
Licenses: custom:neovim
Conflicts: neovim
Provides: neovim=0.5.0
Submitter: quebin31
Maintainer: quebin31
Last Packager: quebin31
Votes: 9
Popularity: 1.99
First Submitted: 2019-03-25 20:28
Last Updated: 2020-10-26 17:00

Dependencies (4)

Required by (96)

Sources (1)

Pinned Comments

quebin31 commented on 2019-04-17 14:17

Starting from commit 85adc2, I changed the versioning of this package using the date it was released, so expect at least daily updates.

Latest Comments

quebin31 commented on 2020-09-11 18:36

@Ataraxy working on it :)

Ataraxy commented on 2020-09-11 09:29

To satisfy nvimpager-git's version requirements, please apply this patch:

index 1f8e1ff..4744c1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs - Nigh
 arch=('x86_64')
 url='https://neovim.io'
 license=('custom:neovim')
-provides=("$_pkgname")
+provides=("$_pkgname"="$pkgver")
 conflicts=("$_pkgname")
 optdepends=('python2-neovim: for Python 2 plugin support, see :help python'
             'python-neovim: for Python 3 plugin support, see :help python'

quebin31 commented on 2020-09-01 18:45

Sorry for the inconveniences, I was kinda busy and I totally forgot to change my known_hosts for the AUR since I have an automated script that changes version and pushes to the AUR (so the AUR helpers work flawlessly)

p00f commented on 2020-08-31 04:45

@kuba-gaj You flagged it out-of-date, please undo it. See the PKGBUILD, it always downloads the latest nightly

(on the flip side, it can't be updated using an aur helper because the version remains the same. To update, you'll have to reinstall it @quebin31)

p00f commented on 2020-06-15 11:50

Please update, there's a new syntax for tree-sitter queries

quebin31 commented on 2019-04-17 14:17

Starting from commit 85adc2, I changed the versioning of this package using the date it was released, so expect at least daily updates.

quebin31 commented on 2019-04-06 03:02

I've kinda optimized the update process, I'll try to update the package every day if there's a new version.

ekaljuk commented on 2019-03-29 18:33

I can confirm I am experiencing the same problem as @scarab5q on my machine. The SHA512 file hash included with this package is incorrect.

scarab5q commented on 2019-03-26 10:11

just tried to install this but got the follwoing error:

==> Validating source files with sha512sums... nvim-linux64.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check! Error downloading sources: neovim-nightly

Is this something I have done wrong or is this a problem on your end ?