Package Details: neon-wallet 0.2.4-1

Git Clone URL: https://aur.archlinux.org/neon-wallet.git (read-only)
Package Base: neon-wallet
Description: Light Wallet for the NEO Blockchain
Upstream URL: http://github.com/CityOfZion/neon-wallet
Licenses: MIT
Submitter: lysergia
Maintainer: lysergia
Last Packager: lysergia
Votes: 1
Popularity: 0.000049
First Submitted: 2018-02-13 06:11
Last Updated: 2018-05-09 15:37

Latest Comments

jankohrasko commented on 2018-05-14 20:41

lysergia: I understand now after reading README from neon wallet repo. It is unfortunate they are not supporting new versions of Node. Anyway, I managed to get it installed using neon-wallet-bin package which has no dependencies.

lysergia commented on 2018-05-13 22:47

Trollwut: Since the node LTS is a "make" dependency, you can build the package in a chroot and still have the latest nodejs installed on your system. Install the devtools package, clone this AUR repo, & run extra-x86_64-build in the cloned directory. Then you can run pacman -U on the built package to install it. I'm running nodejs-10.1.0 & neon-wallet-0.2.4 side-by-side like this.

jankohrasko: If you can get the package to build using nodejs instead of the LTS, I would gladly accept a patch. I love bleeding edge software - that's one of the many reasons I use Arch Linux. But I imaging that'd involve patching the neon wallet code to support the latest version of node. I didn't switch to the LTS to go against the "nature" of Arch Linux, I switched because that's what was needed to get the package to compile.

jankohrasko commented on 2018-05-13 21:48

On top of the comment that was posted earlier, having any package on Arch Linux that is following LTS against nature of Arch Linux (i.e. nodejs-lts-carbon). Packages should be bleeding edge and your dependency basically prevents it system-wide.

Trollwut commented on 2018-05-13 18:22

makedepends nodejs-lts-carbon breaks dependency on nodejs for other packages. Any chance on getting it for "both are ok"? :)