Package Details: ndpi-git r3017.0f8a9948-1

Git Clone URL: https://aur.archlinux.org/ndpi-git.git (read-only, click to copy)
Package Base: ndpi-git
Description: Open and Extensible GPLv3 Deep Packet Inspection Library
Upstream URL: http://www.ntop.org/products/ndpi/
Keywords: forensic network penetration
Licenses: GPL3
Conflicts: ndpi
Provides: ndpi
Submitter: robertfoster
Maintainer: robertfoster (lnslbrty)
Last Packager: lnslbrty
Votes: 1
Popularity: 0.000000
First Submitted: 2015-12-03 16:37
Last Updated: 2021-03-27 19:41

Dependencies (1)

Required by (2)

Sources (1)

Latest Comments

lnslbrty commented on 2021-03-01 13:15

This package is broken at the moment.

To fix this, please apply this patch with patch -p1 < FILE

diff --git a/PKGBUILD b/PKGBUILD index 0b381b7..0fef146 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -1,12 +1,13 @@ # Maintainer: robertfoster

pkgname=ndpi-git -pkgver=1057.6e62367 +pkgver=3008.4bff5957 pkgrel=1 pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library" arch=('i686' 'x86_64') url="http://www.ntop.org/products/ndpi/" license=('GPL3') +requires=('libmaxminddb', 'libgcrypt') provides=('ndpi') conflicts=('ndpi') source=('ndpi::git+https://github.com/ntop/nDPI.git') @@ -18,19 +19,16 @@ pkgver() { }

build() {
- cd ndpi - ./autogen.sh - ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib - make + cd ndpi + CPPFLAGS="${CPPFLAGS} ${CFLAGS}" + ./autogen.sh + ./configure --prefix=/usr --with-pic --includedir=/usr/include --libdir=/usr/lib + make } - package() { - cd ndpi - make DESTDIR="${pkgdir}/" install - mv $pkgdir/usr/include/libndpi-/libndpi $pkgdir/usr/include - rm -r $pkgdir/usr/include/libndpi- - sed -i 's|\/libndpi-2..||g' $pkgdir/usr/lib/pkgconfig/libndpi.pc - sed -i 's=#include "../lib/third_party/include/libcache.h"=#include "libcache.h"=' $pkgdir/usr/include/libndpi/ndpi_typedefs.h - cp -p src/lib/third_party/include/libcache.h $pkgdir/usr/include/libndpi + +package() { + cd ndpi + make DESTDIR="${pkgdir}/" install }

md5sums=('SKIP')