Package Details: ncspot-git 0.0.0.251.5eff818-1

Git Clone URL: https://aur.archlinux.org/ncspot-git.git (read-only)
Package Base: ncspot-git
Description: Cross-platform ncurses Spotify client written in Rust, inspired by ncmpc and the likes.
Upstream URL: https://github.com/hrkfdn/ncspot
Keywords: curses spotify
Licenses: BSD
Conflicts: ncspot
Provides: ncspot
Submitter: nicoulaj
Maintainer: nicoulaj
Last Packager: nicoulaj
Votes: 4
Popularity: 0.766214
First Submitted: 2019-03-12 18:47
Last Updated: 2019-05-11 12:55

Latest Comments

j605 commented on 2019-03-13 21:06

Upstream has changed license to BSD 2-clause now, can you please update it :)

nicoulaj commented on 2019-03-13 18:10

Added git and changed the versioning.

I use rustup so this is why it compiles here. Not sure if there is a clean way to require rustc >= 1.33 ? You can't just add this requirement because it will break for the rustup users.

mrochford commented on 2019-03-13 01:26

This requires >=rustc 1.33.0 for the package to compile and the version in the extra repo right now is 1.32.0

This issue: https://github.com/rust-lang/rust/issues/50202

Fixed in this commit: https://github.com/rust-lang/rust/commit/79bbce488e115f9a553e932832991a14b7bfe20f

sekret commented on 2019-03-12 23:10

Hm, doesn't build... Here's the log https://pastebin.com/MHVGezx5

edit: I tried to build it in a clean chroot. Maybe there's a dependency missing? I know I could try to dig deeper by following the comments by the error, e.g. running rustc --explain E0658, but honestly I don't have all that interest since I quit my Premium account with spotify.

sekret commented on 2019-03-12 22:47

Please add git to makedepends.

And chose a pkgver which increases over time. Yours doesn't...