Package Details: ncl 6.6.2-1

Git Clone URL: https://aur.archlinux.org/ncl.git (read-only)
Package Base: ncl
Description: Ncar Command Language, is an interpreted language designed specifically for scientific data analysis and visualization
Upstream URL: http://www.ncl.ucar.edu
Licenses: Apache
Provides: ncl
Submitter: XavierCLL
Maintainer: XavierCLL
Last Packager: XavierCLL
Votes: 15
Popularity: 0.004606
First Submitted: 2010-09-24 16:46
Last Updated: 2019-06-03 21:15

Pinned Comments

XavierCLL commented on 2017-08-27 03:23

Is necessary before install or update the ncl package, reinstall/rebuild these packages: g2clib, triangle, udunits, hdf4 (>=4.2.14-4). If everything went well in the build, it generates the binary /usr/bin/ncl. For fresh install run 'source /etc/profile' or relogin.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

XavierCLL commented on 2015-10-13 22:41

Hi sundar_ima,
You are right, some packages not was updated after the migrate aur3 to aur4, then I adopted the hdf4-nonetcdf package and update it for supply dependencies for ncl
Try again

sundar_ima commented on 2015-10-13 15:00

Could not build. Throws following error.

error: target not found: hdf4-nonetcdf

XavierCLL commented on 2015-08-18 01:01

Hi @Enoid, fixed! thanks. Try again.

Enoid commented on 2015-08-17 21:04

==> Validating source files with md5sums...
ncl_ncarg-6.3.0.tar.gz ... Passed
triangle.zip ... Passed
ncl.patch ... Passed
includes.patch ... Passed
ncl-libs.patch ... Passed
Site.local ... FAILED
ncarg.sh ... Passed
hluresfile ... Passed
ncl.install ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build ncl.

I had to use this workaround
packer -G ncl
cd ncl
makepkg -g >> PKGBUILD
makepkg
sudo pacman -U ncl-6.3.0-2-x86_64.pkg.tar.xz

Enoid commented on 2015-08-17 20:34

Hi Xavier,

The package fails the md5sum test :
==> Validating source files with md5sums...
ncl_ncarg-6.3.0.tar.gz ... Passed
triangle.zip ... Passed
ncl.patch ... Passed
includes.patch ... Passed
ncl-libs.patch ... Passed
Site.local ... FAILED
ncarg.sh ... Passed
hluresfile ... Passed
ncl.install ... Passed
==> ERROR: One or more files did not pass the validity check
==> ERROR: Makepkg was unable to build ncl.

I had to use this workaround https://bbs.archlinux.org/viewtopic.php?id=178626

XavierCLL commented on 2015-06-18 17:40

Thanks Julian, I tested and build/work fine.

Update dependencie from openmotif to lesstif

julian.carpenter commented on 2015-06-02 07:57

hey epsilom,
could we switch from openmotif to lesstif as dependency ?
both are providing the same tools but openmotif is not
used by any other software than ncl while lesstif is needed
for some programms. and of course they are in conflict.
i already built my ncl with lesstif instead of openmotif
and all went fine...there should be no problem at all.

thanks !

XavierCLL commented on 2015-03-19 06:20

updated to v6.3.0, please test.

julian.carpenter commented on 2014-09-12 10:06

the update fixed the problem ... thx !

julian.carpenter commented on 2014-08-13 10:26

thanks for the binary ...
e-mail with attached log file is in your mailbox