Package Details: ncbi-vdb 2.10.0-2

Git Clone URL: https://aur.archlinux.org/ncbi-vdb.git (read-only)
Package Base: ncbi-vdb
Description: The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives.
Upstream URL: https://github.com/ncbi/ncbi-vdb
Licenses: custom:PublicDomain
Provides: ncbi-vdb
Submitter: apolih
Maintainer: apolih (gamanakis)
Last Packager: gamanakis
Votes: 3
Popularity: 0.025525
First Submitted: 2016-01-29 22:48
Last Updated: 2019-08-25 03:21

Latest Comments

pwl commented on 2016-11-18 08:27

@apolih, thanks for making this a package. This seems to be a very intricate piece of software indeed. I saw a lot of errors concerning https when running the tests, I'm afraid this might be the reason for the build failing.

apolih commented on 2016-11-17 17:25

Yes, I can add python-virtualenv. I'm not familiar enough with the software to know if the HTTPS changes are causing the issue. Actually navigating the build system is a challenge in itself.

Thanks for your patch and comments.

pwl commented on 2016-11-17 15:08

From the upstream repository:

"We have released new tools with version 2.8.0 that are HTTPS compatible and M-15-13 compliant as of October 7, 2016. Please be certain to update all of your binaries and configuration files."

could this be the issue? This package is in version 2.7.0, which is outdated according to the above quote.

pwl commented on 2016-11-17 14:51

It still doesn't work, I created an upstream PR to fix some cipher test errors, for now you could add the patch https://gist.github.com/pwl/5bce940f7da8ed1552e60e4736306078. But even with this patched up it doesn't seem to build properly and fails at the tests.

EDIT: I managed to install it by disabling the tests, but that might be risky.

pwl commented on 2016-11-17 13:55

Could you please add python-virtualenv as a dependency? It is used by the test suite when building the package.