Package Details: nbdkit 1.24.0-2

Git Clone URL: https://aur.archlinux.org/nbdkit.git (read-only, click to copy)
Package Base: nbdkit
Description: NBD server toolkit
Upstream URL: https://github.com/libguestfs/nbdkit
Licenses: custom: BSD
Submitter: t-8ch
Maintainer: t-8ch
Last Packager: t-8ch
Votes: 1
Popularity: 0.000926
First Submitted: 2019-02-22 14:36
Last Updated: 2021-01-10 14:57

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

rwmjones commented on 2020-03-16 09:04

Soft dependency. However if it turns out that the nbd standalone plugin is actually broken then compiing without libnbd around seems like it will always cause a hang, until we get that fixed upstream.

t-8ch commented on 2020-03-16 08:59

@rwmjones would you recommend making libnbd a hard or soft dependency for the nbdkit package?

rwmjones commented on 2020-03-16 08:47

And yes there is a circular dependency between libnbd <-> nbdkit, but: (1) Neither dependency is essential and (2) Old versions of one package can be used to build new versions of the other package.

rwmjones commented on 2020-03-16 08:45

One thing that strikes me about your test is that you are using the "standalone" version of nbdkit-nbd-plugin, the one which is implemented using raw NBD protocol calls. Since we wrote libnbd we basically never use or test the standalone version of the plugin, and instead we use the libnbd-based one. The two plugins are here:

https://github.com/libguestfs/nbdkit/blob/master/plugins/nbd/nbd-standalone.c https://github.com/libguestfs/nbdkit/blob/master/plugins/nbd/nbd.c

The easy way to test this theory would be to add libnbd as a dependency of nbdkit in AUR. nbdkit's ./configure should just pick up the new dependency automatically. (See also https://aur.archlinux.org/packages/libnbd)

This has other advantages - the nbdkit test suite is more thorough when libnbd is available since having it enables much more complete testing to be done. You should find that many tests which were "SKIP" before will run after this.

rwmjones commented on 2020-03-16 08:31

This shouldn't be happening, and seems to indicate a bug in the server:

test-parallel-nbd.sh.log:nbdkit: backend.c:523: backend_flush: Assertion `h->can_flush == 1' failed.

I'll ask my colleague who wrote the nbd plugin to take a look.

svenne_k commented on 2020-03-15 16:49

Ok, found some logs:

Pre ctrl-c https://svenne.dk/nbdkit-20200315/nbdkit-logs-20200315.tar.gz

Post ctrl-c https://svenne.dk/nbdkit-20200315/nbdkit-logs-20200315b.tar.gz

t-8ch commented on 2020-03-09 20:20

Or test-ssh.sh.log

t-8ch commented on 2020-03-09 20:20

And $srcdir/src/nbdkit-1.18.0/tests/test-parallel-nbd.sh.log does not exist?

svenne_k commented on 2020-03-09 09:19

newest version, makepkg from "download snapshot".

Same problem...

t-8ch commented on 2020-03-09 08:50

Are you using an AUR helper? If so, please try to build without it. Also try the latest version from AUR 1.18.0-1.