Package Details: nagstamon 3.4.1-2

Git Clone URL: https://aur.archlinux.org/nagstamon.git (read-only, click to copy)
Package Base: nagstamon
Description: Nagios status monitor for the desktop
Upstream URL: https://nagstamon.ifw-dresden.de/
Licenses: GPL
Submitter: ghostbuster
Maintainer: ghostbuster
Last Packager: ghostbuster
Votes: 16
Popularity: 1.03
First Submitted: 2015-08-09 16:15
Last Updated: 2020-12-04 18:01

Latest Comments

1 2 3 4 Next › Last »

ghostbuster commented on 2020-12-04 18:09

Thanks gerdesj for the archive.

I was able to compare both archive and check the changes. There were some code formatting changes and one additional check in the area of the user interface. In the meantime the upstream developer confirmed that a rebuild of the release archives was needed for Fedora after the 3.4.1 release. He assumes that this rebuild triggered a full rebuild and thus a change of checksums.

The PKGBUILD has been updated with the new checksums.

gerdesj commented on 2020-12-04 15:40

File sent to ghostbuster

ghostbuster commented on 2020-12-04 15:24

Could you send me send the old archive file by e-mail? I'd like to compare the two versions to speed up the update of this package and give some hopefully helpful feedback to the developer.

gerdesj commented on 2020-12-04 10:32

I have found a copy of the .tar.gz that matches the 927... md5sum on my work PC that I'm not using much these days ...

A diff against both the old and new .tar.gz shows about 40 lines of changed code. It looks benign - patches and a few comments. I'm no expert but there are no signs of anything that looks like a compromise.

ghostbuster commented on 2020-12-02 13:21

I can confirm, that the checksums have changed for the downloadable packages, but as there is no obvious reason why checksums should change ~11 month after release, I will double-check first before updating this package.

e_fadeev commented on 2020-12-02 11:30

Need to change md5sums and sha256sums for install ver. 3.4.1

Patch:

15c15
<         '927b7a6e0e3e1c747dc31e5c12c1d00d'
---
>         'f35a65d9f8b9b02cbecb190ac9737c23'
18c18
<         '2d26cf4d64a6e27fe55f1c5e5f042af511bcb09876ae16a456aee5800a98adea'
---
>         '7a9611f40b08269bba4100ab2598ee089c7d0ebc6c4e9d7132689342f71150ec'

Result PKGBUILD:

# Maintainer: ghostbuster <aur@sieverdingbeck.com>
_pkgname=Nagstamon
pkgname=nagstamon
pkgver=3.4.1
pkgrel=1
pkgdesc="Nagios status monitor for the desktop"
depends=('python-pyqt5' 'qt5-multimedia' 'qt5-svg' 'python-requests' 'python-beautifulsoup4' 'python-keyring' 'python-psutil' 'python-requests-kerberos' 'python-lxml' 'python-dbus')
arch=('any')
url="https://nagstamon.ifw-dresden.de/"
license=('GPL')
source=(
        "https://nagstamon.ifw-dresden.de/files/stable/$_pkgname-$pkgver.tar.gz"
)
md5sums=(
        'f35a65d9f8b9b02cbecb190ac9737c23'
)
sha256sums=(
        '7a9611f40b08269bba4100ab2598ee089c7d0ebc6c4e9d7132689342f71150ec'
)

package() {
cd "$srcdir/$_pkgname"
# setup.py imports AppInfo from Nagstamon.Config which leads to a import of keyring
# importing keyring fails in a fakeroot environment, which seems to be somehow related to a the keyring connection init triggered by the import
# to avoid the issue setup.py is rewritten here to resolve the need for the AppInfo import
name=$(sed '0,/class AppInfo/d' Nagstamon/Config.py  | grep "NAME " | sed -e "s/^[\t ]*NAME = '//" -e "s/'$//")
version=$(sed '0,/class AppInfo/d' Nagstamon/Config.py  | grep "VERSION " | sed -e "s/^[\t ]*VERSION = '//" -e "s/'$//")
sed -i setup.py -e "s/from Nagstamon.Config import AppInfo//" -e "s/AppInfo.NAME/'${name}'/" -e "s/AppInfo.VERSION/'${version}'/"
sed -i Nagstamon/setup.py -e "s/from Nagstamon.Config import AppInfo//" -e "s/AppInfo.NAME/'${name}'/" -e "s/AppInfo.VERSION/'${version}'/"
sed -i setup.py -e "s/from Nagstamon.Helpers import get_distro//"
sed -i setup.py -e "s/get_distro()/('arch', '', 'Arch Linux')/"
python setup.py install --prefix=/usr --root="$pkgdir"
mv $pkgdir/usr/bin/nagstamon.py $pkgdir/usr/bin/nagstamon
}

ziopera commented on 2020-01-07 15:00

This is my(working) PKGBUILD for version 3.4

# Maintainer: ghostbuster <aur@sieverdingbeck.com>
_pkgname=Nagstamon
pkgname=nagstamon
pkgver=3.4
pkgrel=1
pkgdesc="Nagios status monitor for the desktop"
depends=('python-pyqt5' 'qt5-multimedia' 'qt5-svg' 'python-requests' 'python-beautifulsoup4' 'python-keyring' 'python-psutil' 'python-requests-kerberos' 'python-lxml' 'python-dbus')
arch=('any')
url="https://nagstamon.ifw-dresden.de/"
license=('GPL')
source=(
        "https://nagstamon.ifw-dresden.de/files/stable/$_pkgname-$pkgver.tar.gz"
)
md5sums=(
        '76c3b7cabb8143e94f6845cd63516ffe'
)
sha256sums=(
        '9ad3fa7ad46239bc53f4153e9e8487d2fa93aa8d66085f1c5e9fdef7c5394b7e'
)

package() {
  cd "$srcdir/$_pkgname"
  # setup.py imports AppInfo from Nagstamon.Config which leads to a import of keyring
  # importing keyring fails in a fakeroot environment, which seems to be somehow related to a the keyring connection init triggered by the import
  # to avoid the issue setup.py is rewritten here to resolve the need for the AppInfo import
  name=$(sed '0,/class AppInfo/d' Nagstamon/Config.py  | grep "NAME " | sed -e "s/^[\t ]*NAME = '//" -e "s/'$//")
  version=$(sed '0,/class AppInfo/d' Nagstamon/Config.py  | grep "VERSION " | sed -e "s/^[\t ]*VERSION = '//" -e "s/'$//")
  sed -i setup.py -e "s/from Nagstamon.Config import AppInfo//" -e "s/AppInfo.NAME/'${name}'/" -e "s/AppInfo.VERSION/'${version}'/"
  sed -i Nagstamon/setup.py -e "s/from Nagstamon.Config import AppInfo//" -e "s/AppInfo.NAME/'${name}'/" -e "s/AppInfo.VERSION/'${version}'/"
  sed -i setup.py -e "s/platform.dist()/('arch', '', '')/g"
  python setup.py install --prefix=/usr --root="$pkgdir"
  mv $pkgdir/usr/bin/nagstamon.py $pkgdir/usr/bin/nagstamon
}

paschty commented on 2020-01-02 10:30

I did this to upgrade to 3.4:


$ git diff origin/master
diff --git a/PKGBUILD b/PKGBUILD
index 657fef8..83f5d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: ghostbuster aur@sieverdingbeck.com
 _pkgname=Nagstamon
 pkgname=nagstamon
-pkgver=3.2.1
+pkgver=3.4
 pkgrel=2
 pkgdesc="Nagios status monitor for the desktop"
 depends=('python-pyqt5' 'qt5-multimedia' 'qt5-svg' 'python-requests' 'python-beautifulsoup4' 'python-keyring' 'python-psutil' 'python-requests-kerberos' 'python-lxml' 'python-dbus')
@@ -12,10 +12,10 @@ source=(
         "https://nagstamon.ifw-dresden.de/files/stable/$_pkgname-$pkgver.tar.gz"
 )
 md5sums=(
-        '9ab4d49c1bb88c898c3ca2a1fc8a9065'
+        '76c3b7cabb8143e94f6845cd63516ffe'
 )
 sha256sums=(
-        'a834460e78dc01f62171a83c4a11d890702264ed662863dff39edaf14ae98880'
+        '9ad3fa7ad46239bc53f4153e9e8487d2fa93aa8d66085f1c5e9fdef7c5394b7e'
 )

package() {

wuestengecko commented on 2019-12-27 11:04

@maxdevaine, to report a new upstream version please use the "Flag package out of date" link in the box on the right.

maxdevaine commented on 2019-12-27 08:04

Download url not working, there is new version : https://nagstamon.ifw-dresden.de/files/stable/Nagstamon-3.4.tar.gz