Package Details: mythtv 1:30.0-6

Git Clone URL: https://aur.archlinux.org/mythtv.git (read-only)
Package Base: mythtv
Description: A Homebrew PVR project
Upstream URL: https://www.mythtv.org/
Keywords: mythtv
Licenses: GPL
Conflicts: mythplugins-mythvideo, myththemes
Replaces: mythplugins-mythvideo, myththemes
Submitter: Barthalion
Maintainer: Taijian
Last Packager: Taijian
Votes: 27
Popularity: 0.002635
First Submitted: 2018-01-07 17:35
Last Updated: 2019-05-25 12:53

Dependencies (47)

Sources (8)

Pinned Comments

Taijian commented on 2019-03-09 11:53

Important Note on AUR packages in general:

For AUR packages, you - as the user installing the package - assume the role that a package maintainer has for regular repo packages.

That means that the responsibility to recompile the package whenever a package B that your package depends on changes. For repo packages, maintainers do this for you and re-release the package with an updated build number (e.g. -1 to -2). AUR mainainers will not do this, because there is no change to the PKGBUILD. You need to recompile locally, whenever this happens.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

Taijian commented on 2019-01-17 10:41

OK everybody, thank you all for the helpful input. New version incorporating your suggestions in incoming!

martyg commented on 2019-01-17 01:45

Release notes are up https://www.mythtv.org/wiki/Release_Notes_-_30

martyg commented on 2019-01-17 01:05

Since we have the hood open on this thing, allow me to suggest adding Wants=mysqld.service to mythbackend.service. Without this, MySQL can/will be stopped before mythbackend on shutdown, which is a bad thing.

ImNtReal commented on 2019-01-17 00:58

It also looks like libhdhomerun needs to be an optional dependency. When compiled on a system that doesn't have it installed it won't work with HDHomerun devices. I'm recompiling now to make sure installing libhdhomerun fixes my issue.

ImNtReal commented on 2019-01-16 02:31

If the v30 that's been tagged is correct, it looks like building requires libxnvctrl.

gary9872 commented on 2019-01-05 02:46

add requirement perl-net-upnp 1.4.4-1 instead of allowing 1.4.3-3 (old perl module)

mark.clegg commented on 2018-12-28 20:10

I just renamed/removed the tvdb_api folder. ttvdb.py then recreates it when next run.

keepitsimpleengr commented on 2018-12-28 19:27

@mark.clegg Could you explain what or how you clear the pickle cache at /home/mythtv/.mythtv/cache/tvdb_api Thanks :)

mark.clegg commented on 2018-12-28 11:13

With the latest update to python-urllib3 (1.24) I found that the TV DB metadata grabber (ttvdb.py) was no longer working, reporting no module named ordered-dict. Clearing the pickle cache in the mythtv home directory seems to resolve. ~mythtv/.mythtv/cache/tvdb_api

Taijian commented on 2018-10-10 13:23

Yes, if any of the packages/codecs that mythtv depends on get updated, mythtv has to be rebuild in order to work again. For repo packages this is done by the maintainer with a build number bump (e.g. -1 to -2), for AUR packages, YOU are the packager, so everyone has to do this themselves.