Package Details: mysql-workbench-git 8.0.12.r0.g7d05cc5df-1

Git Clone URL: https://aur.archlinux.org/mysql-workbench-git.git (read-only)
Package Base: mysql-workbench-git
Description: A cross-platform, visual database design tool developed by MySQL - git checkout
Upstream URL: https://www.mysql.com/products/workbench/
Licenses: GPL2
Conflicts: mysql-workbench
Provides: mysql-workbench
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 5
Popularity: 0.378797
First Submitted: 2015-10-29 13:51
Last Updated: 2018-08-24 08:01

Dependencies (32)

Required by (0)

Sources (9)

Latest Comments

1 2 Next › Last »

scippio commented on 2019-07-23 08:27

please change: https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-8.0.12-src.tar.gz to https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-8.0.16-src.tar.gz

because error:

==> Making package: mysql-workbench-git 8.0.12.r0.g7d05cc5df-1 (Tue Jul 23 10:26:30 2019)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating mysql-workbench git repo...
Fetching origin
  -> Updating mysql-server git repo...
Fetching origin
  -> Downloading mysql-connector-c++-8.0.12-src.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://cdn.mysql.com/Downloads/Connector-C++/mysql-connector-c++-8.0.12-src.tar.gz

+ build working only when I update boost to version 1.69

Almagest commented on 2019-07-10 17:18

Note that this package does not work properly without gnome-keyring.

karcher commented on 2018-10-08 17:44

Getting an error:

==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issues...
==> WARNING: Package contains reference to $srcdir
usr/bin/mysql-workbench-bin
usr/lib/mysql-workbench/libmdcanvasgtk.so.8.0.12
usr/lib/mysql-workbench/modules/wb.model.grt.so.8.0.12
usr/lib/mysql-workbench/libwbpublic.so.8.0.12
usr/lib/mysql-workbench/libgrt.so.8.0.12
usr/lib/mysql-workbench/libgdal.so.20.4.1
usr/lib/mysql-workbench/liblinux_utilities.so.8.0.12
usr/lib/mysql-workbench/libwbprivate.so.8.0.12
==> Creating package "mysql-workbench-git"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: mysql-workbench-git 8.0.12.r0.g7d05cc5df-1 (Mon 08 Oct 2018 07:31:24 PM CEST)
==> Cleaning up...
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) mysql-workbench-git-8.0.12.r0.g7d05cc5df-1

Total Installed Size:  96.90 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                           [###################################################] 100%
(1/1) checking package integrity                                                         [###################################################] 100%
(1/1) loading package files                                                              [###################################################] 100%
(1/1) checking for file conflicts                                                        [###################################################] 100%
(1/1) checking available disk space                                                      [###################################################] 100%
:: Processing package changes...
(1/1) installing mysql-workbench-git                                                     [###################################################] 100%
Optional dependencies for mysql-workbench-git
    python2-pyodbc: database migration
:: Running post-transaction hooks...
(1/5) Cleaning pacman cache...
==> no candidate packages found for pruning
(2/5) Updating icon theme caches...
(3/5) Arming ConditionNeedsUpdate...
(4/5) Updating the desktop file MIME type cache...
(5/5) Updating the MIME type database...
/usr/share/mime/packages/mysql-workbench.xml:1: parser error : Document is empty

^
Failed to parse '/usr/share/mime/packages/mysql-workbench.xml'

eworm commented on 2018-08-24 08:24

Updated.

But please keep in mind that building from git does not give any benefit compared to the version in official repositories. Oracle only pushes releases to git.

leo_11 commented on 2018-08-23 22:18

Good evening, I've an issue, while I'm installing MySQL Workbench. This is the steps:

[leo@ThinkPad-T61 mysql-workbench-git]$ makepkg ==> Creazione del pacchetto: mysql-workbench-git 6.3.9.r0.g1972008-1 (ven 24 ago 2018 00:05:47 CEST) ==> Controllo delle dipendenze durante l'avvio in corso... ==> Controllo delle dipendenze durante la compilazione in corso... ==> Download dei sorgenti in corso... -> Aggiornamento del repository mysql-workbench git in corso... Fetching origin -> Aggiornamento del repository mysql-server git in corso... Fetching origin -> Aggiornamento del repository mysql-connector-cpp git in corso... Fetching origin -> È stato trovato gdal-2.2.3.tar.xz -> È stato trovato boost_1_59_0.tar.bz2 -> È stato trovato antlr-3.4-complete.jar -> È stato trovato 0001-mysql-workbench-no-check-for-updates.patch -> È stato trovato 0002-disable-unsupported-operating-system-warning.patch -> È stato trovato 0003-add-option-to-hide-nonstandard-server-warning.patch -> È stato trovato 0005-gdal-use-CPLFree.patch -> È stato trovato 0006-mysql-include-my_dir.patch -> È stato trovato 0007-gdal-json-c-0-13.patch -> È stato trovato arch_linux_profile.xml ==> Validazione di source file con sha256sums... mysql-workbench ... Ignorato mysql-server ... Ignorato mysql-connector-cpp ... Ignorato gdal-2.2.3.tar.xz ... Verificato boost_1_59_0.tar.bz2 ... Verificato antlr-3.4-complete.jar ... Verificato 0001-mysql-workbench-no-check-for-updates.patch ... Verificato 0002-disable-unsupported-operating-system-warning.patch ... Verificato 0003-add-option-to-hide-nonstandard-server-warning.patch ... Verificato 0005-gdal-use-CPLFree.patch ... Verificato 0006-mysql-include-my_dir.patch ... Verificato 0007-gdal-json-c-0-13.patch ... Verificato arch_linux_profile.xml ... Verificato ==> Estrazione dei sorgenti in corso... -> Creazione di una copia di lavoro del repository mysql-workbench git in corso... Ripristina il branch 'makepkg' -> Creazione di una copia di lavoro del repository mysql-server git in corso... Ripristina il branch 'makepkg' -> Creazione di una copia di lavoro del repository mysql-connector-cpp git in corso... Ripristina il branch 'makepkg' -> Estrazione di gdal-2.2.3.tar.xz usando bsdtar in corso... -> Estrazione di boost_1_59_0.tar.bz2 usando bsdtar in corso... -> Estrazione di antlr-3.4-complete.jar usando bsdtar in corso... ==> Avvio di prepare() in corso... can't find file to patch at input line 5 Perhaps you used the wrong -p or --strip option? The text leading up to this was:


|diff --git a/mysys/my_symlink.c b/mysys/my_symlink.c |index ab0d76e91d0..b96d78e8c17 100644 |--- a/mysys/my_symlink.c |+++ b/mysys/my_symlink.c


File to patch:

What's the File to patch?

Thanks in advance!

timofonic commented on 2017-10-23 20:25

I found the following in the cmake error log. Can this be true?

/usr/bin/ld: cannot find -lpthreads



-- Found Threads: TRUE
-- Found SWIG: /usr/bin/swig (found version "3.0.12")
-- Found PythonLibs: /usr/lib/libpython2.7.so (found suitable version "2.7.14", minimum required is "2.6")
-- Found PY_paramiko: 2.3.1
-- Found MySQL: /home/timofonic/.cache/pacaur/mysql-workbench-git/src/install-bundle/usr/include (found suitable version "5.7.20", minimum required
is "5.6.0")
MySQL_INCLUDE_DIRS: /home/timofonic/.cache/pacaur/mysql-workbench-git/src/install-bundle/usr/include
MySQL_LIBRARIES: -L/home/timofonic/.cache/pacaur/mysql-workbench-git/src/install-bundle/usr/lib -lmysqlclient -lpthread -lm -lrt -latomic -ldl
-- Found LibXml2: /usr/lib/libxml2.so (found version "2.9.5")
-- Found OpenGL: /usr/lib/libGL.so
CMake Error at build/cmake/Modules/FindMySQLCppConn.cmake:55 (file):
file STRINGS file
"/home/timofonic/.cache/pacaur/mysql-workbench-git/src/install-bundle/usr/include/cppconn/version_info.h"
cannot be read.
Call Stack (most recent call first):
CMakeLists.txt:134 (find_package)


ERROR Unable to detect MySQLCppConn version
-- Found VSQLITE: /usr/lib/libvsqlitepp.so
VSQLITE INCLUDE DIR: /usr/include
VSQLITE LIB DIR: -L/usr/lib -lvsqlitepp
-- Found GDAL: /home/timofonic/.cache/pacaur/mysql-workbench-git/src/install-bundle/usr/lib/libgdal.so
-- Boost version: 1.65.1
-- Found unixODBC: /usr/lib/libodbc.so
Found unixodbc, using it as ODBC library.
-- Checking for modules 'libpcre;libpcrecpp'
-- Found libpcre, version 8.41
-- Found libpcrecpp, version 8.41
-- Checking for module 'cairo>=1.5.12'
-- Found cairo, version 1.14.6
-- Checking for module 'uuid'
-- Found uuid, version 2.30.2
-- Checking for module 'libzip'
-- Found libzip, version 1.2.0
-- Checking for module 'gnome-keyring-1'
-- Found gnome-keyring-1, version 3.12.0
-- Looking for include file sys/prctl.h
-- Looking for include file sys/prctl.h - found
-- Looking for strtol
-- Looking for strtol - found
-- Looking for strtoll
-- Looking for strtoll - found
-- Looking for strtold
-- Looking for strtold - found
-- Looking for strtoull
-- Looking for strtoull - found
-- Looking for strtoimax
-- Looking for strtoimax - found
-- Looking for strtoumax
-- Looking for strtoumax - found
Using bundled Antlr C runtime
CMake Deprecation Warning at /usr/share/cmake-3.9/Modules/UseSWIG.cmake:228 (message):
SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead.
Call Stack (most recent call first):
library/forms/swig/CMakeLists.txt:36 (swig_add_module)


CMake Deprecation Warning at /usr/share/cmake-3.9/Modules/UseSWIG.cmake:228 (message):
SWIG_ADD_MODULE is deprecated. Use SWIG_ADD_LIBRARY instead.
Call Stack (most recent call first):
library/forms/swig/CMakeLists.txt:49 (swig_add_module)


[mysql] Generating parser files...
Selected MySQL parser
-- Configuring incomplete, errors occurred!
See also "/home/timofonic/.cache/pacaur/mysql-workbench-git/src/mysql-workbench/CMakeFiles/CMakeOutput.log" ( https://paste.pound-python.org/show/IIh9QjbBNpDVjVVM0O4Z/ ).
See also "/home/timofonic/.cache/pacaur/mysql-workbench-git/src/mysql-workbench/CMakeFiles/CMakeError.log" ( https://paste.pound-python.org/show/Fl1jk86JVnXHtV7NBTsu/ ).
==> ERROR: A failure occurred in build().
Aborting...

eworm commented on 2016-06-26 19:07

There should be more output than that...
As I successfully built just yesterday... Perhaps your disk space filled up?

lungaonline commented on 2016-06-26 16:05

I am getting the following error:
-- Configuring incomplete, errors occurred!
See also "/home/goodman/builds/mysql-workbench-git/src/mysql-workbench/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...

Unfortunately, I do not see anything on the log that can help me.

eworm commented on 2016-06-24 20:45

Ups, looks like I dropped antlr too early... This is still required for the git version.

I can not change anything about git. The repositories are handled by makepkg.

markc commented on 2016-06-24 07:42

FWIW my build attempt failed with a "antlr-3.4-complete.jar file could not be found" and I note your comment about removing boost and antlr for certain versions. Would you care to elaborate a little please?

Also, if you could add "--depth 1" to the git clones then up to 800Mb of download bandwidth (and drive space) could be saved.