Package Details: mycli 1.20.1-1

Git Clone URL: https://aur.archlinux.org/mycli.git (read-only, click to copy)
Package Base: mycli
Description: A Terminal Client for MySQL with AutoCompletion and Syntax Highlighting
Upstream URL: https://github.com/dbcli/mycli
Keywords: cli mariadb mysql
Licenses: BSD
Submitter: aabmass
Maintainer: loonies
Last Packager: loonies
Votes: 26
Popularity: 1.46
First Submitted: 2015-08-05 15:33
Last Updated: 2019-08-26 15:02

Pinned Comments

loonies commented on 2019-12-06 11:43

Prior to flagging the package out-of-date or reporting build errors please:

  • Make sure that your system is up-to-date (pacman -Syu)
  • Rebuild and reinstall dependencies (especially ones from AUR)
  • Rebuild and reinstall the package

Do not expect AUR packages to trigger rebuild or suggest bumping "pkgrel" number. This is expected behaviour and the way Arch packing is designed to work.

For more information read the official documentation and man pages.

Latest Comments

1 2 3 4 Next › Last »

loonies commented on 2019-12-06 11:43

Prior to flagging the package out-of-date or reporting build errors please:

  • Make sure that your system is up-to-date (pacman -Syu)
  • Rebuild and reinstall dependencies (especially ones from AUR)
  • Rebuild and reinstall the package

Do not expect AUR packages to trigger rebuild or suggest bumping "pkgrel" number. This is expected behaviour and the way Arch packing is designed to work.

For more information read the official documentation and man pages.

loonies commented on 2019-12-06 11:42

@deconf Sorry for late response. Try to rebuild python-cli_helpers, python-pymysql, and mycli. This was the minimum required for my mycli installation to start working again after Python 3.8 upgrade.

ccxex29 commented on 2019-12-04 12:16

@deconf I had this problem as well. This is a known problem with AUR updates. If what the python said is sqlparse, then take a look at the dependency list. There is python-sqlparse. Since this is also an AUR package, you need to clean install python-sqlparse.

deconf commented on 2019-11-28 09:54

@loonies Of course, below is my error message using mycli

pkg_resources.Context ual Version Conflict:
 (sqlparse 0.2.4 (/usr/lib/python3.8/site-packages), Requirement.parse('sqlparse<0.4.0,>=0.3.0'), {'mycli'})

pkg_resources.DistributionNotFound: The 'sqlparse<0.4.0,>=0.3.0' distribution was not found and is required by mycli

loonies commented on 2019-11-27 18:06

@deconf Can you be more specific?

deconf commented on 2019-11-27 11:17

@loonies How do I fix if the upgrade breaks dependencies?

loonies commented on 2019-09-03 17:50

Both, mycli 1.20.0 and 1.20.1 depend on python-sqlparse >=0.3.0,<0.4.0

At the time of writing python-sqlparse version is 0.3.0 and given Arch Linux is a rolling release distribution it is expected that the system has the latest packages installed, therefore there is no need to specify dependent package version if already satisfied. Arch Linux users are required to upgrade dependencies prior to upgrading the package. Version pinning is used if dependency upgrade breaks a package.

I have no idea why python-sqlparse-0_3_0 exists in AUR if there is already a package in community repository.

References:

keevitaja commented on 2019-09-03 11:32

mycli 1.20 requires sqlparse<0.4.0,>=0.3.0

you can find it also in aur: python-sqlparse-0_3_0

loonies commented on 2018-12-17 21:59

Added, thanks!

Yuanji commented on 2018-12-11 14:22

python-paramiko should be in optdepends that can support ssh function.

https://gist.github.com/masakichi/62bf9e7aa33d2d2fd9d51d01ece97ccb

ref: https://github.com/dbcli/mycli/blob/master/setup.py#L109