Package Details: muwire 0.8.4-1

Git Clone URL: https://aur.archlinux.org/muwire.git (read-only, click to copy)
Package Base: muwire
Description: An I2P file sharing program
Upstream URL: https://muwire.com/
Licenses: GPL3
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 4
Popularity: 0.29
First Submitted: 2019-10-03 14:23
Last Updated: 2020-11-13 14:55

Required by (0)

Sources (3)

Latest Comments

1 2 Next › Last »

dbermond commented on 2020-11-04 18:52

@txtsd AUR helpers are not supported. Manage the needed pgp key[1][2][3] and use makepkg[4]. The Arch Wiki is your friend.

[1] https://wiki.archlinux.org/index.php/GnuPG#Use_a_keyserver

[2] https://wiki.archlinux.org/index.php/GnuPG#Searching_and_receiving_keys

[3] https://wiki.archlinux.org/index.php/GnuPG#Key_servers

[4] https://wiki.archlinux.org/index.php/Makepkg

txtsd commented on 2020-11-04 03:58

:: PGP keys need importing:
 -> 471B9FD45517A5ED101FC57DA72832072D525E41, required by: muwire
:: Importing keys with gpg...
gpg: keyserver receive failed: No data
problem importing keys

What do?

Tio commented on 2020-09-27 16:20

Works now after the last update.

necklace commented on 2020-09-05 22:05

If you need devtools to build this then it should be a dependency. It doesn't look like you need it though. But one does need to set the current java version with archlinux-java set java-14-openjdk (or java-13-openjdk),

Tio commented on 2020-08-16 13:48

Manjaro is Arch basically, but ok. I understand. Cheers

dbermond commented on 2020-08-15 03:16

@Tio Sorry, but Manjaro is not supported. Package is building fine on Arch Linux.

Tio commented on 2020-08-15 01:41

Error on Manjaro:

   ^

2 errors


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':gui:compileGroovy'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.5.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 2m 1s
32 actionable tasks: 24 executed, 8 up-to-date
==> ERROR: A failure occurred in build().
    Aborting...

dbermond commented on 2020-04-01 23:01

@GI_Jack I'm using the default Arch Linux java-runtime version, which currently is java 13 opendjk (same as yours). Everything is fine here.

Try to build the package in a clean chroot with devtools and it should work. That's how I build it.

GI_Jack commented on 2020-04-01 22:30

mabey there is a dependancy not added? What version of java are you using?

big edit: output of failure:

https://pastebin.com/DG2hW7JN

$ pacman -Qs jre
    JRE version 6 or later.
local/jre-openjdk 13.0.2.u8-1
    OpenJDK Java 13 full runtime environment
local/jre-openjdk-headless 13.0.2.u8-1
    OpenJDK Java 13 headless runtime environment
local/jre11-openjdk 11.0.6.u10-1
    OpenJDK Java 11 full runtime environment
local/jre11-openjdk-headless 11.0.6.u10-1
    OpenJDK Java 11 headless runtime environment
local/jre8-openjdk 8.u242-1
    OpenJDK Java 8 full runtime environment
local/jre8-openjdk-headless 8.u242-1
    OpenJDK Java 8 headless runtime environment

$ archlinux-java status
Available Java environments:
  java-11-openjdk
  java-13-openjdk (default)
  java-8-openjdk

dbermond commented on 2020-04-01 01:01

@GI_Jack I cannot reproduce your error. Package builds fine and works without any problems here. Please give more information than just a single error line.