Package Details: mupen64plus-video-gliden64 4.0-1

Git Clone URL: https://aur.archlinux.org/mupen64plus-video-gliden64.git (read-only, click to copy)
Package Base: mupen64plus-video-gliden64
Description: A new generation, open-source graphics plugin for N64 emulators
Upstream URL: https://github.com/gonetz/GLideN64
Licenses: GPL
Submitter: Presence
Maintainer: Presence
Last Packager: Presence
Votes: 6
Popularity: 0.000000
First Submitted: 2015-05-04 14:41
Last Updated: 2019-04-10 03:40

Latest Comments

Presence commented on 2016-12-28 05:01

Ah, thanks for opening an issue. It works fine with that environment variable set.

I forgot I added a way to set that environment variable in mupen64plus-qt to fix crashing on an earlier version:
https://github.com/dh4/mupen64plus-qt#linux-gliden64-workaround

gourdcaptain commented on 2016-12-28 03:10

Reply on the bugtracker:
"This is because GLideN64 is using a bit of "old school" OpenGL code. You can work around this by doing:

export MESA_GL_VERSION_OVERRIDE=3.3COMPAT

Before launching mupen64plus

You can also try RetroArch + GLupeN64, which is a RetroArch core that uses a modified version of GLideN64 that uses modern OpenGL code." - Works for me.

gourdcaptain commented on 2016-12-28 03:05

https://github.com/gonetz/GLideN64/issues/1313 - Posted an issue here - it's kind of hard to do a detailed bug log from this little feedback from the program.

Presence commented on 2016-12-28 02:03

I have the exact same issue. Glad it's not just me.

Was going to test and see if I could find any sort of log output that might be useful in pinpointing the issue. He's waited so long to release a new version it would take awhile to find the exact commit that broke things.

I was going to submit a bug report on this when I got a chance. I didn't spot one for it with a quick glance. Feel free to submit one if you want:
https://github.com/gonetz/GLideN64/issues

gourdcaptain commented on 2016-12-27 19:45

For some reason I'm getting a black screen in Mupen64plus when I try using this plugin. (Both standalone and with m64py). Any suggestions?

gamezelda commented on 2015-11-22 23:51

Plugin works, great for Lens of Truth in Zelda OoT - Thanks!