Package Details: munge 0.5.14-1

Git Clone URL: https://aur.archlinux.org/munge.git (read-only, click to copy)
Package Base: munge
Description: An authentication service for creating and validating credentials. It is designed to be highly scalable for use in an HPC cluster environment.
Upstream URL: https://github.com/dun/munge/wiki
Keywords: authentication credentials daemon encryption security slurm
Licenses: GPL3, LGPL3
Submitter: tegenf
Maintainer: edh
Last Packager: edh
Votes: 13
Popularity: 0.000000
First Submitted: 2011-01-28 14:17
Last Updated: 2020-02-21 14:19

Pinned Comments

edh commented on 2016-02-26 12:32

I removed the obsolete init script from the package completely in a recent commit. Therefore merely SystemD is supported from now on. I did this change since I expect that most Arch Linux users stick to SystemD and that probably no one using this package actually made use of those extra files.
Please let me now immediately in case I am wrong about this and I will add those files again as soon as possible.

Latest Comments

1 2 3 Next › Last »

edh commented on 2020-02-21 14:10

@cmcc

The package is still maintained though unfortunately I missed the notification from my upstream tracking service and I did not receive an out-of-date notification from the AUR for whatever reason.

Either way, the package is now up-to-date again. Sorry for the delay.

cmcc commented on 2020-02-21 12:08

I'm wondering if this package is still mantained, it was marked out-of-date 10 days ago due new upstream release but no action was taken here on AUR...

edh commented on 2017-07-27 18:01

@kyechou
Thanks for the hint. I added the suggested configure flag.

kyechou commented on 2017-07-27 04:00

Hi.
The build fails due to the issue (https://github.com/dun/munge/issues/54).
The bug seems to be fixed in the next release, but it would be appreciated if you could add the configuration option (--with-crypto-lib=libgcrypt), as mentioned in the thread, for the current release.
Thanks a lot for the maintenance!

edh commented on 2016-02-26 12:32

I removed the obsolete init script from the package completely in a recent commit. Therefore merely SystemD is supported from now on. I did this change since I expect that most Arch Linux users stick to SystemD and that probably no one using this package actually made use of those extra files.
Please let me now immediately in case I am wrong about this and I will add those files again as soon as possible.

edh commented on 2015-12-14 23:02

@BruceWyxv
Thanks a lot!!! I totally missed that! I broke it with the new indentation but it should be working again.

BruceWyxv commented on 2015-12-14 21:39

It doesn't appear the the MD5sum for arch_munge.init was updated. I get a value of '3cdaf129182a96e220c5c42ee3ac63fe' after the edits.

@edh
Thanks for maintaining this package, it's been a nifty resource!

edh commented on 2015-03-08 18:34

Systemd service-files are now handled properly.
Furthermore only /var/run is now pruned instead of the whole /var directory. Pacman won't install anything to /run (or /var/run) but this is not a reasen to remove /var/log and /var/lib.

edh commented on 2015-03-08 18:31

Systemd service-files are now handled properly.

tegenf commented on 2015-02-17 13:00

* Did the corrections suggested by wookietreiber.
* Package tested using namcap
* Installed succesfully on a local machine with a recent arch install