Package Details: mumps 5.2.1-3

Git Clone URL: https://aur.archlinux.org/mumps.git (read-only)
Package Base: mumps
Description: Sparse solver library using Gaussian elimination
Upstream URL: http://mumps.enseeiht.fr
Licenses: custom
Conflicts: mumps-par, mumps4
Provides: mumps
Submitter: mickele
Maintainer: MartinDiehl
Last Packager: MartinDiehl
Votes: 13
Popularity: 0.48
First Submitted: 2009-04-05 16:37
Last Updated: 2019-11-26 15:25

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

eleftg commented on 2014-10-06 14:51

Any news regarding the error?

eleftg commented on 2014-09-26 11:30

make[1]: Entering directory '/home/george/aur-builds/mumps/src/MUMPS_4.10.0/examples'
mpif77 -o ssimpletest -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -fPIC ssimpletest.o ../lib/libsmumps.a ../lib/libmumps_common.a -L/usr/lib -lparmetis-3 -lmetis-4 -L../PORD/lib/ -lpord -L/usr/lib -lptesmumps -lptscotch -lptscotcherr -lscotchmetis -lscotch -lscalapack -llapack -L/usr/lib/openmpi -lmpi_mpifh -lmpi_usempi -lmpi -ldl -lhwloc -lblas -lpthread
/usr/bin/ld: cannot find -lmpi_usempi
collect2: error: ld returned 1 exit status
Makefile:28: recipe for target 'ssimpletest' failed
make[1]: *** [ssimpletest] Error 1
make[1]: Leaving directory '/home/george/aur-builds/mumps/src/MUMPS_4.10.0/examples'
Makefile:42: recipe for target 'sexamples' failed
make: *** [sexamples] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Trying to locate libmpi_usempi the results are the following:

locate mpi_usempi

/usr/lib/openmpi/libmpi_usempi_ignore_tkr.so
/usr/lib/openmpi/libmpi_usempi_ignore_tkr.so.0
/usr/lib/openmpi/libmpi_usempi_ignore_tkr.so.0.0.0
/usr/lib/openmpi/libmpi_usempif08.so
/usr/lib/openmpi/libmpi_usempif08.so.0
/usr/lib/openmpi/libmpi_usempif08.so.0.5.0

???

mickele commented on 2014-08-31 20:26

I added parmetis3 and scotch_esmumps5 in AUR.
I created these two packages because it seems mumps-4.10 doesn't work well with parmetis-4. Look at http://mumps.enseeiht.fr/index.php?page=faq#18.
Symilar problem for scotch_esmumps (look at http://www.code-aster.org/forum2/viewtopic.php?id=18497).

eolianoe commented on 2014-08-27 19:23

LIBPAR have been modified, but why did you change the depencies to parmetis3 and scotch_esmumps5 whose don't exist in the AUR ?

eolianoe commented on 2014-08-16 19:46

Flagged out-of-date because LIBPAR need to be changed in Makefile.inc

heitzmann commented on 2014-06-19 00:41

For me the error seemed to be that the openmpi fortran lib is not libmpi_f77, but limmpi_mpifh and libmpi_usempi, so I just replaced it on the Makefile (line 77):

LIBPAR = $(SCALAP) -L/usr/lib/openmpi -lmpi_mpifh -lmpi_usempi -lmpi -ldl -lhwloc

blixawillbargeld commented on 2014-05-21 20:08

@Gug: thanks for your PKGBUILD, did work for me too. AUR Version gives me an error as well.

gdolle commented on 2013-08-10 15:34

I had to change the Makefile.inc and PKGBUILD to make it compile. If some are interested,
https://github.com/dolleg/AUR/tree/master/lib/mumps/4.10.0

gdolle commented on 2013-08-03 14:27

I got a conflict between scotch_esmumps and ptscotch
(It seems that scotch_esmumps already provide ptscotch so ptscotch>5.17 might not be required)
Someone can confirm ?

gdolle commented on 2013-08-03 14:25

I got a conflict between scotch_esmumps and ptscotch
(It seems that scotch_esmumps already provide ptscotch so ptscotch>5.17 might not be required)
Someone can confirm ?