Package Details: mumble-snapshot 1:1.3.0_rc2-1

Git Clone URL: https://aur.archlinux.org/mumble-snapshot.git (read-only, click to copy)
Package Base: mumble-snapshot
Description: A high quality voice chat program.
Upstream URL: https://www.mumble.info/
Licenses: BSD
Conflicts: mumble
Provides: mumble
Submitter: synapse84
Maintainer: None
Last Packager: IdleGandalf
Votes: 7
Popularity: 0.000000
First Submitted: 2014-08-01 01:30
Last Updated: 2019-06-26 23:23

Pinned Comments

IdleGandalf commented on 2018-03-21 23:46

New PGP key (2019) to verify signature: 5B8CF87BB893449B

Latest Comments

« First ‹ Previous 1 2

synapse84 commented on 2015-12-08 09:22

@Kiwii Upgrading the package to Qt5 is something I've had on my todo list for a while. I've kept it held back on Qt4 for a few reasons, but the main thing stopping it now is data loss with the server list. During the Qt5 migration the search location for the mumble sqlite database file got changed from `QDesktopServices::DataLocation` (~/.local/share/data) to `QStandardPaths::DataLocation` (~/.local/share). This of course results in mumble not being able to load the existing client database.

I've posted an issue to the mumble github, but haven't gotten around to fixing it myself. Since compiling against Qt4 is starting to cause issues, I'll see about fixing it and upgrading this package to Qt5.

https://github.com/mumble-voip/mumble/issues/1702

The latest snapshot (874 in my case) doesn't compile because of a copy assignment operation with a class that doesn't allow copying.

Also, Good catch on the PLUGIN_PATH, I'll update that soon.

*EDIT 2015-12-11*
I have submitted a pull request to mumble to migrate data from Qt4 to Qt5 builds. I'll upgrade both of my AUR mumble packages to Qt5 when my pull request is merged.
https://github.com/mumble-voip/mumble/pull/1971

*EDIT 2015-12-13*
Mumble pull request was merged, updated to Qt5.

Kiwii commented on 2015-12-07 21:39

I also just noticed the pkgbuild defines PLUGIN_PATH=/usr/lib/mumble but in the package function it copies liblink.so and libmanual.so into /usr/lib/mumble/plugins/ so mumble doesn't actually find them.

Kiwii commented on 2015-12-07 20:58

Any particular reason the pkgbuild doesn't use Qt5 yet? During build with Qt4 it gives the warning:

> Mumble client support for Qt 4 is deprecated and will be dropped
> completely in the future. We highly recommend switching to
> building Mumble with Qt 5. When built with Qt 4, Mumble might
> lack certain bug-fixes and capabilities available when built
> with Qt 5 already.

Also, the second latest snapshot 867_g197f13e builds fine with Qt5 when copying depends, makedepends and build lines from the mumble-git package into this pkgbuild. The latest snapshot 868_g21673bf wouldn't build at all for me, so I don't know what's up with that.