Package Details: muffin-git 4.2.0.r2.gf0d02aa-1

Git Clone URL: https://aur.archlinux.org/muffin-git.git (read-only)
Package Base: muffin-git
Description: A window manager for GNOME
Upstream URL: https://github.com/linuxmint/muffin
Licenses: GPL
Conflicts: cinnamon<4.2.0, muffin
Provides: muffin=4.2.0.r2.gf0d02aa
Submitter: chenxiaolong
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 85
Popularity: 0.045777
First Submitted: 2012-01-11 21:48
Last Updated: 2019-07-03 20:33

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2012-03-31 17:26

I'm a bit lost on how i'm suppose to do this x)
Besides I'm pretty sure i would end up making the worst stable package ever D:
There's no way to like get the previous revision that was working until really few days ago ? :/

Anonymous comment on 2012-03-31 16:38

Wait until this is merged, or cherry pick the fixes: https://github.com/linuxmint/Cinnamon/pull/587

Anonymous comment on 2012-03-31 16:37

Isn't compiling after going through gtk3-git problems:

compositor/meta-backround-actor.c:547:7: error: Too many arguments to function 'cogl_texture_pixmap_x11_new_EXP'

Anonymous comment on 2012-03-31 09:19

You need to activate [gnome-unstable] repo and do a full system update.
Cinnamon currently requires Gnome 3.4, which is not yet in [extra].

Anonymous comment on 2012-03-31 09:12

Doesn't compile for me.

...
checking for msgfmt... (cached) /usr/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/bin/msgfmt
checking for xgettext... (cached) /usr/bin/xgettext
checking for ALL... yes
checking for MUFFIN_MESSAGE... no
configure: error: Package requirements (gtk+-3.0 >= 3.3.3) were not met:

Requested 'gtk+-3.0 >= 3.3.3' but version of GTK+ is 3.2.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MUFFIN_MESSAGE_CFLAGS
and MUFFIN_MESSAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Anonymous comment on 2012-03-30 18:32

I can confirm that. Built fine without both the gtk_3.3 workaround and Werror patch.

Anonymous comment on 2012-03-30 18:12

The workaround for integrating the gtk_3.3 branch can be removed now, since it is now merged in master.
Possibly the Werror patch can be removed, too, since there was an fix for an error, but I am not sure if it was that error.

Anonymous comment on 2012-03-19 21:37

I solved the problem by myself.

I checked again full system upgrade and I found a new update for gnome-desktop. After installing I got back gdm and gnome-shell to work. I recompiled muffin and cinnamon and everything runs fine now. I can load cinnamon.

Thank you for supporting cinnamon in Arch world.

Anonymous comment on 2012-03-19 20:58

I installed todays' update and I can't enter cinnamon DE nor gnome-shell. After installing i did cinnamon --replace and I lost the window manager (running cinnamon-git). I did rc.d restart gdm but gdm doesn't come up anymore, even if I reboot. I uninstalled all cinnamon and muffin stuff and I cannot have GDM back. I reinstalled cinnamon (not git) but the problem remains. Any diretion?

Anonymous comment on 2012-03-19 18:18

Cool :-) But I think you should remove the comment about uncommenting the lined to make it work with gtk 3.3, since that is not needed anymore.