Package Details: muffin-git 4.2.0.r2.gf0d02aa-1

Git Clone URL: https://aur.archlinux.org/muffin-git.git (read-only)
Package Base: muffin-git
Description: A window manager for GNOME
Upstream URL: https://github.com/linuxmint/muffin
Licenses: GPL
Conflicts: cinnamon<4.2.0, muffin
Provides: muffin=4.2.0.r2.gf0d02aa
Submitter: chenxiaolong
Maintainer: eschwartz
Last Packager: eschwartz
Votes: 85
Popularity: 0.046009
First Submitted: 2012-01-11 21:48
Last Updated: 2019-07-03 20:33

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2012-04-05 14:23

I answered that in cinnamon-git comments:

You need to change those lines in muffin-git:

if $(pkg-config --atleast-version 1.9 cogl-1.0 &>/dev/null); then
_gitroot='https://github.com/rat4/muffin.git'
else
_gitroot='https://github.com/linuxmint/muffin.git'
fi

to:
_gitroot='https://github.com/linuxmint/muffin.git'

and remove that lines there:

if $(pkg-config --atleast-version 1.9 cogl-1.0 &>/dev/null); then
cd "${srcdir}/${_gitname}"
git checkout gtk_3.3
git checkout master
git merge gtk_3.3
fi

It was a workaround which is not needed anymore.

Anonymous comment on 2012-04-05 14:20

hmm, now it says:

==> The local files are updated.
==> GIT checkout done or server timeout
==> Starting build...
error: pathspec 'gtk_3.3' did not match any file(s) known to git.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build muffin-git.

Anonymous comment on 2012-04-05 14:10

ok, I submit :) I happen to have access to 4 computers at home, so I have put testing on this quadcore, that I scarcely use, but it might be a good place to find out what gnome 3.4 is destroying - hehe

Thank you for your kind and rapid reply. Will unflag Out-of-date.

Anonymous comment on 2012-04-05 13:54

If you don't want to use testing, the only chance to use this package is to wait, until gnome 3.4 hits [extra]. Muffin-git requires Gnome 3.4, because otherwise it wouldn't work in Gnome 3.4.
Or you use muffin stable version instead of git. But there is currently no package available (muffin in AUR is not Cinnamon's muffin), so either create one or wait until someone else does. You could ask in the cinnamon comments or especially Morfeo, the maintainer-

Anonymous comment on 2012-04-05 13:46

Further, if gnome 3 takes away cinnamon, then gnome goes to the trash.

Anonymous comment on 2012-04-05 13:43

I dont use testing and since gnome 3.4 is not yet in extra, I dunno what to do

Anonymous comment on 2012-04-05 13:38

You need to enable [testing], but there will be still errors, since cinnamon/muffin are not completely Gnome/GTK 3.4 compatible yet.

//edit: OK, currently no errors with [testing].

Anonymous comment on 2012-04-05 13:30

Hmm, seems muffins is looking for gtk3.3.3. Won't install.


configure: error: Package requirements (gtk+-3.0 >= 3.3.3) were not met:

Requested 'gtk+-3.0 >= 3.3.3' but version of GTK+ is 3.2.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MUFFIN_MESSAGE_CFLAGS
and MUFFIN_MESSAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build muffin-git.

ma2t commented on 2012-04-04 19:28

Yep.

chenxiaolong commented on 2012-04-04 19:22

Don't be sorry, you just wanted to help :D