Package Details: mssql-server 15.0.4188.2-2

Git Clone URL: https://aur.archlinux.org/mssql-server.git (read-only, click to copy)
Package Base: mssql-server
Description: Microsoft SQL Server for Linux
Upstream URL: https://docs.microsoft.com/en-us/sql/linux/sql-server-linux-overview?view=sql-server-ver15
Licenses: unknown
Submitter: flash2k2
Maintainer: doctorzeus
Last Packager: doctorzeus
Votes: 23
Popularity: 1.73
First Submitted: 2016-11-17 09:25
Last Updated: 2021-11-26 12:45

Latest Comments

1 2 3 4 5 6 Next › Last »

kvasthval commented on 2021-11-28 14:21

The old libldap can be downloaded from the Arch Linux Archive: https://archive.archlinux.org/packages/l/libldap/libldap-2.4.59-2-x86_64.pkg.tar.zst After installation, "libldap" should be added to IgnorePkg in /etc/pacman.conf in order to avoid unwanted upgrades.

However, simply changing this PKGBUILD to depend on the libldap24 AUR package instead might be a better solution. The downgrade procedure will break other packages using libldap because they now expect to find the 2.6 version from [core].

fishnet37222 commented on 2021-11-28 14:03

I was able to get this package to install by editing the PKGBUILD to specify "libldap24" as a dependency instead of "libldap<=2.4.56". So far everything seems to be working fine, and I also have the "libldap" package from the main Arch repo installed.

doctorzeus commented on 2021-11-28 04:05

@joaonunatings : There is probably a far better work around but I would try uninstalling libldap if you don't have anything else installed that depends on it on your system.

As I mentioned earlier in the comments I have simply kept my version of libldap back at 2.4.59-2 rather than installing the AUR package so not sure on installing both packages.

Either way should hopefully be a temporary restriction until Microsoft releases an update.

joaonunatings commented on 2021-11-27 19:29

yay outputs the following when updating from 15.0.4153.1-1 to 15.0.4188.2-2:

Could not find all required packages:
libldap<=2.4.59 (Wanted by: mssql-server) 

I have installed the following libldap packages: libldap 2.6.0-2 and libldap24 2.4.59-1

kvasthval commented on 2021-11-26 12:52

@doctorzeus Yes, but the <2.6 version is only available from the archive. It would be nice not having to manually downgrade yet another package if it's not necessary. :) Thanks for maintaining, and for your quick response!

doctorzeus commented on 2021-11-26 12:41

@kvasthval your right old dep since mssql server hasn't supported 32 bit since mssql2014 so will update..

However I believe you can find lib32-libldap in the multilib repo?

kvasthval commented on 2021-11-26 10:59

Is lib32-libldap really required? It has been working just fine for me for a week now, even though I only downgraded libldap when the issue started. My lib32-libldap is still the new version (2.6.0-1). I cannot find any 32-bit binaries nor libraries in the x86_64 release. There doesn't even seem to be a 32-bit version for Linux, so I don't think it's relevant. :)

jorgemota commented on 2021-11-22 03:57

You can install libldap24 to avoid error "error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory"

doctorzeus commented on 2021-11-20 10:43

For anyone having issues starting mssql-server with error "error while loading shared libraries: liblber-2.4.so.2: cannot open shared object file: No such file or directory".

A workaround is to downgrade lib32-libldap from 2.6.0-1 => 2.4.59-1 and libldap from 2.6.0-2 => 2.4.59-2 respectively (check your package cache).

MrHritik commented on 2020-12-15 21:20

The upstream URL is invalid. Please fix.
EDIT: Fixed