Package Details: msodbcsql 17.4.2.1-1

Git Clone URL: https://aur.archlinux.org/msodbcsql.git (read-only, click to copy)
Package Base: msodbcsql
Description: Microsoft® ODBC Driver 17 for SQL Server®
Upstream URL: https://blogs.msdn.microsoft.com/sqlnativeclient/
Licenses: custom
Submitter: mtorromeo
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 19
Popularity: 0.94
First Submitted: 2016-10-06 14:48
Last Updated: 2019-10-18 13:17

Latest Comments

1 2 Next › Last »

jens.churchill commented on 2019-10-18 11:39

centos updated to version 1.0.2k-19, edit PKGBUILD to avoid NOT FOUND error.

User should verify this, but for convenience sake:

sha256sum openssl-libs-1.0.2k-19.el7.x86_64.rpm

8a907020f9b1697cb8971158b3a5279e5b54e5637f55dcce751f1610a2ed6452 openssl-libs-1.0.2k-19.el7.x86_64.rpm

hoobert commented on 2019-10-13 20:20

change PKGBUILD to this file to build: https://gist.github.com/hoob3rt/12f08681cde8c12d563194775d1949a9

works as of 13.10.19

chuano commented on 2019-09-27 09:08

Package openssl-libs-1.0.2k-16.el7.x86_64.rpm NOT FOUND current release version: openssl-libs-1.0.2k-19.el7.x86_64.rpm

alessiofachechi commented on 2019-09-09 12:56

I've been investigating on "08001" issues when using named instances:

Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : Login timeout expired.
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : MAX_PROVS: Error Locating Server/Instance Specified [xFFFFFFFF]. .
Sqlcmd: Error: Microsoft ODBC Driver 17 for SQL Server : A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online..

Then I updated to msodbcsql 17.4.1.1 and everything worked fine.

A patch for msodbcsql 17.4.1.1 is available here: https://gist.github.com/alessiofachechi/273a1297ada5316fba729dea6e2a2d47

Erazx commented on 2018-12-11 03:11

Package openssl-libs-1.0.2k-12.el7.x86_64.rpm NOT FOUND current release version: openssl-libs-1.0.2k-16.el7.x86_64.rpm

bl4n commented on 2018-10-08 07:31

Is there any way to add /opt/microsoft/msodbcsql/include in the system so that it find header files?

For an example, while attempting to compile esqlOC (from GNUCobol), I need msodbcsql.h, but the system didn't find it. I use so CPLUS_INCLUDE_PATH, but I'm sure there is another way to detect header files, isn't it?

Erazx commented on 2018-05-10 03:52

==> ERROR: Failure while downloading http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-1.0.2k-8.el7.x86_64.rpm

replaced with openssl-libs-1.0.2k-12.el7.x86_64.rpm,looks fine.

diff:

7c7

--- _opensslver=1.0.2k-8

+++ _opensslver=1.0.2k-12

16c16

--- http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-$_opensslver.el7.x86_64.rpm)

+++ https://mirrors.aliyun.com/centos/7/os/x86_64/Packages/openssl-libs-$_opensslver.el7.x86_64.rpm)

18c18

--- '3e355d70d78d8578ccc1dc474948dc5a8fd4b4e4c9508ff7321488c0e4796bf1')

+++ 'fee49e741f2b1e1af1871343fe0ac595e1ae48970f6d42b5a6f215e7aa47ded5')

kama commented on 2017-09-21 08:14

http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-1.0.1e-60.el7.x86_64.rpm not found

Eremiell commented on 2017-04-29 06:34

diff --git a/PKGBUILD b/PKGBUILD
index 76246e4..f01f6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>

pkgname=msodbcsql
-pkgver=13.1.4.0
-pkgrel=3
+pkgver=13.1.6.0
+pkgrel=1
pkgdesc="Microsoft® ODBC Driver 13 for SQL Server®"
arch=('x86_64')
url="https://blogs.msdn.microsoft.com/sqlnativeclient/"
@@ -11,10 +11,12 @@ license=('custom')
depends=('unixodbc' 'krb5' 'curl')
makedepends=('patchelf')
options=('!strip')
+provides=('msodbcsql')
+conflicts=('msodbcsql')
source=(https://packages.microsoft.com/rhel/7/prod/msodbcsql-$pkgver-1.x86_64.rpm
http://mirror.centos.org/centos/7/os/x86_64/Packages/openssl-libs-1.0.1e-60.el7.x86_64.rpm)
-sha256sums=('402eb8f7ebf2957cb800589787554376d5624b00b76fedf9a41e2e5f2a602cbe'
- '8a36abefd04bbbe8272650afb80c516b592e4e065faac131144e047204ace7dd')
+sha512sums=('62b7b5b3007a10dcfa57ff91d52c86ebb73883a1900a297e704701e04315adcd0e273ce36f2eed8b8dd79c0e3d308ba7cf381e20c4f642ea0fde6e69c3a1e05c'
+ '8097714c4b1c01a8202ab40d3dd8df0e78eac957c3bc0d8419e697e1c8f7634e04216cc15519b696dfaf33e50ae0948a206240b7ccfc6d560db4dc11c205e5e9')
install=msodbcsql.install

package() {

chris-chr commented on 2017-04-26 12:41

I updated the package and it works, thank you!