Package Details: msitools 0.101-3

Git Clone URL: https://aur.archlinux.org/msitools.git (read-only, click to copy)
Package Base: msitools
Description: Set of programs to inspect and build Windows Installer (.MSI) files
Upstream URL: https://wiki.gnome.org/msitools
Licenses: GPL, LGPL
Submitter: Misery
Maintainer: SamLukeYes (yan12125)
Last Packager: SamLukeYes
Votes: 22
Popularity: 0.71
First Submitted: 2016-01-22 14:25
Last Updated: 2021-04-27 16:14

Latest Comments

SamLukeYes commented on 2021-04-27 16:04

The pre-built package is now available on archlinuxcn

ghderty commented on 2021-03-11 15:40

yes, whole base-devel group is installed

in addition, except for the absence of the LICENSE file, the msitools-git package compiled successfully in the same environment.

btw, its fails exactly on package() stage for me

SamLukeYes commented on 2021-03-11 02:50

@ghderty I tried again on OBS with a slightly updated PKGBUILD, which was also pushed to AUR just now. It built successfully without any issue, but I don't think the slight changes have any magic to solve a compiling error. Again, have you installed base-devel in your building environment?

ghderty commented on 2021-03-10 20:30

0.101 also fails to compile for me even in a clean chroot. the errors are the same as for delthas

SamLukeYes commented on 2021-03-09 02:27

@delthas I can't reproduce your issue in a clean chroot. Have you installed base-devel in your build environment? According to the Fedora source package, msitools requires bison and gettext when building, which are both in base-devel.

delthas commented on 2021-03-08 21:36

This package doesn't compile fine anymore since yesterday's 0.101. CI builder logs (scroll down a bit for the errors): https://yui.runners.sr.ht/logs/453389/log

tools/wixl/wixl.p/msi.c:556:2: error: unknown type name 'WixlMsiTable'
  556 |  WixlMsiTable parent_instance;
      |  ^~~~~~~~~~~~
tools/wixl/wixl.p/msi.c:561:2: error: unknown type name 'WixlMsiTableClass'
  561 |  WixlMsiTableClass parent_class;
      |  ^~~~~~~~~~~~~~~~~

cpuheater commented on 2021-01-07 17:28

This package seems to be missing two makedepends dependencies: meson and gobject-introspection.

Also the LICENSE file was renamed in the git source, so I had to change install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE" to install -Dm644 copyright "$pkgdir/usr/share/licenses/$_pkgname/LICENSE".

TheGoliath commented on 2020-05-27 17:18

https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=msitools-git I've updated the git version. If there is another update relying on meson, feel free to have a look at it :)