Package Details: msbuild 16.4+xamarinxplat.2019.11.27.22.07-2

Git Clone URL: https://aur.archlinux.org/msbuild.git (read-only, click to copy)
Package Base: msbuild
Description: Xamarin implementation of the Microsoft build system
Upstream URL: https://github.com/mono/msbuild
Licenses: MIT
Submitter: fmauNeko
Maintainer: fmauNeko
Last Packager: fmauNeko
Votes: 3
Popularity: 0.014096
First Submitted: 2019-04-17 13:23
Last Updated: 2020-01-16 08:13

Latest Comments

1 2 3 4 Next › Last »

fusion809 commented on 2020-01-22 06:09

@fmauNeko: never mind, just ran yay -Syu and for some inexplicable reason the build ran successfully this time.

fusion809 commented on 2020-01-20 17:00

@fmauNeko: dotnet-host.

fmauNeko commented on 2020-01-20 15:38

@fusion809: Do you have dotnet-host or dotnet-host-bin installed ?

fusion809 commented on 2020-01-20 11:47

I keep getting this build error:

/data/.cache/yay/msbuild/src/msbuild-16.4/.packages/microsoft.dotnet.arcade.sdk/1.0.0-beta.19517.3/tools/Tools.proj : error MSB4242: The SDK resolver "Microsoft.DotNet.MSBuildSdkResolver" failed to run. hostfxr assembly:<unknown assembly> type:<unknown type> member:(null)

with version 16.4+xamarinxplat.2019.11.27.22.07-2. I get that error twice per attempted build. I am doing a clean build, yet I keep getting this error.

Terence commented on 2020-01-16 23:46

Can't build the new version, I'm getting: msbuild-16.4/artifacts/toolset/restore.proj : error : Unable to load the service index for source <https://www.myget.org/F/container-tools-for-visual-studio/api/v3/index.json>.

EDIT: Now I'm getting a bunch of

msbuild-16.4/artifacts/toolset/restore.proj : error : Failed to retrieve information about 'Microsoft.DotNet.Arcade.Sdk' from remote source 'https://dotnetmyget.blob.core.windows.net/artifacts/dotnet-core/nuget/v3/flatcontainer/microsoft.dotnet.arcade.sdk/index.json'.

EDIT2: Weird, it fixed itself.

Terence commented on 2020-01-09 23:05

You might want to pin a message here or when building the package to use ulimit -n 4096 if encountering the "too many open files" error or make the package temporarily increase the file limit with ulimit -n

blspider commented on 2020-01-09 09:16

thanks, using yay seems to work... it's weird as I've been using pamac for a long time, but well, as long as I can install it :)

fmauNeko commented on 2020-01-09 08:59

@blspider: I have no idea how pamac handles AUR packages, but it works fine with makepkg and yay.

blspider commented on 2020-01-09 08:48

hello, I can't install msbuild, it doesn't do much :

[benoit@Hermes ~]$ pamac build msbuild Clonage des fichiers de construction de msbuild... Vérification des dépendances de msbuild... [benoit@Hermes ~]$ Any clue ?

fmauNeko commented on 2019-11-29 15:31

16.4 has been pushed, depending on Mono 6.4.0. Also the libhostfxr.so copy error should be fixed.