Package Details: msbuild-stable 16.0_xamarinxplat.2018.09.26.17.53_0xamarin3_ubuntu1404b1-1

Git Clone URL: https://aur.archlinux.org/msbuild-stable.git (read-only, click to copy)
Package Base: msbuild-stable
Description: Xamarin implementation of the Microsoft build system
Upstream URL: https://github.com/mono/msbuild
Keywords: msbuild
Licenses: MIT
Conflicts: msbuild
Provides: msbuild
Submitter: EagleXiang
Maintainer: jtmb
Last Packager: jtmb
Votes: 48
Popularity: 1.36
First Submitted: 2017-11-16 09:33
Last Updated: 2019-02-19 05:08

Required by (21)

Sources (1)

Latest Comments

1 2 Next › Last »

boggogo commented on 2019-11-25 19:55

I was able to install the package after manually upgrading it

HunabKu commented on 2019-11-23 06:47

Need to use 16.04 version instead of 18.04 to prevent depends problems :
https://download.mono-project.com/repo/ubuntu/pool/main/m/msbuild/msbuild_16.4+xamarinxplat.2019.09.09.15.03-0xamarin5+ubuntu1604b1_all.deb

GrbavaCigla commented on 2019-10-07 20:20

The current version is 16.4 To update, change _pkgver=16.4+xamarinxplat.2019.09.09.15.03-0xamarin5+ubuntu1804b1.

meowxiik commented on 2019-08-31 18:49

@PedroHLC, the whole thing is part of download URL for the binary so it has to be somewhere.

Also anyone who wants to update this package for themselfs edit the _pkgver to:

_pkgver=16.3+xamarinxplat.2019.08.08.00.55-0xamarin2+ubuntu1804b1

This is the newest version as of writing this.

FabioLolix commented on 2019-08-22 07:53

This package should be called msbuild-16-bin

PedroHLC commented on 2019-07-05 15:54

does "_pkgver" has to be that long??

jtmb commented on 2018-03-08 05:57

@globalenemy I have built the package with mono in Arch repos as well as with mono-alpha and mono-beta with no errors. I would recommend reinstalling your mono and trying again.

globalenemy commented on 2018-03-06 22:26

it conflicts with several msbuild files wich are located in mono. "usr/lib/mono/msbuild/15.0/bin/Roslyn/[..].dll"

jtmb commented on 2018-03-06 16:25

@globalenemy, what conflict are you getting exactly?

The package requires a mono above version 5, I personally use mono-alpha but it looks like mono-beta should work as well.

globalenemy commented on 2018-03-06 11:21

cant install package due to conflict with "mono" but "mono" is a dependency :\