Package Details: mpss-micmgmt-python 3.8.1-1

Git Clone URL: https://aur.archlinux.org/mpss.git (read-only, click to copy)
Package Base: mpss
Description: miclib python wrapper of Intel® Manycore Platform Software Stack
Upstream URL: https://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss
Keywords: coprocessor intel manycore mpss phi xeon
Licenses: LGPL2.1
Groups: mpss
Submitter: marcelhuber
Maintainer: image28
Last Packager: marcelhuber
Votes: 4
Popularity: 0.015411
First Submitted: 2016-07-28 14:17
Last Updated: 2017-02-10 09:36

Pinned Comments

image28 commented on 2020-07-02 05:29

Getting closer to updating this, have some of the packages rebuilt, however I haven't finished re-writting the kernel driver. Looking into using the version from AMD's rocm driver.

Latest Comments

1 2 Next › Last »

damme commented on 2021-03-31 21:42

I am unable to compile this, I'm getting the following error and am unable to figure out how to fix it..

make -w -I/opt/mpss/src/mpss-metadata -C miclib install
make[1]: Entering directory '/opt/mpss/src/mpss-micmgmt/miclib'
g++ -g -Wall -Werror -Wextra -std=c++0x -fPIC -I/opt/mpss/pkg/build/usr/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DMPSS_COMMIT=\"'3c34597ac134cb21e966b24fa7ea077806db4f06'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'root@Aux'\" -DMPSS_BUILTON=\"'2021-03-31 23:38:30 +0200'\" -I. -Iinclude -Isrc -c src/mic_device.cpp -o objs/mic_device.o
g++ -g -Wall -Werror -Wextra -std=c++0x -fPIC -I/opt/mpss/pkg/build/usr/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DMPSS_COMMIT=\"'3c34597ac134cb21e966b24fa7ea077806db4f06'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'root@Aux'\" -DMPSS_BUILTON=\"'2021-03-31 23:38:30 +0200'\" -I. -Iinclude -Isrc -c src/knc_device.cpp -o objs/knc_device.o
g++ -g -Wall -Werror -Wextra -std=c++0x -fPIC -I/opt/mpss/pkg/build/usr/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DMPSS_COMMIT=\"'3c34597ac134cb21e966b24fa7ea077806db4f06'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'root@Aux'\" -DMPSS_BUILTON=\"'2021-03-31 23:38:30 +0200'\" -I. -Iinclude -Isrc -c src/miclib.cpp -o objs/miclib.o
g++ -g -Wall -Werror -Wextra -std=c++0x -fPIC -I/opt/mpss/pkg/build/usr/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -DMPSS_COMMIT=\"'3c34597ac134cb21e966b24fa7ea077806db4f06'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'root@Aux'\" -DMPSS_BUILTON=\"'2021-03-31 23:38:30 +0200'\" -I. -Iinclude -Isrc -c src/host_platform.cpp -o objs/host_platform.o
g++ objs/mic_device.o objs/knc_device.o objs/miclib.o objs/host_platform.o objs/miclib_exception.o /opt/mpss/src/mpss-metadata/mpss-metadata.o -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now  -shared -Wl,-soname=libmicmgmt.so.0 -lscif -Wl,--version-script,micmgmt.ver -o libs/libmicmgmt.so
/usr/bin/ld: cannot find -lscif
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:75: libs/libmicmgmt.so] Error 1
make[1]: Leaving directory '/opt/mpss/src/mpss-micmgmt/miclib'
make: *** [Makefile:80: install_lib] Error 2
make: Leaving directory '/opt/mpss/src/mpss-micmgmt'
==> ERROR: A failure occurred in package_mpss-micmgmt-miclib().
    Aborting...

sl1pkn07 commented on 2021-01-16 22:59

myo fail to build, and i'm not able to solve :S

sl1pkn07 commented on 2021-01-13 18:17

works with clang if use the patch and add, for silence warnings, this in the pkgbuild

  sed -e '/COIProcessLoadLibraryFromFile@@COI_1.0/d' \
      -e '/COIProcessLoadLibraryFromMemory@@COI_1.0/d' \
      -i mpss-coi/src/include/internal/coi_version_asm.h

but i'm not sure is the deal thing

greetings

sl1pkn07 commented on 2021-01-13 18:03

seems this patch and add -DCOI_LIBRARY_VERSION=2

diff --git mpss-coi/src/api/process/process_source.cpp.orig mpss-coi/src/api/process/process_source.cpp
old mode 100644
new mode 100755
index 5f83075..6459be6
--- mpss-coi/src/api/process/process_source.cpp.orig
+++ mpss-coi/src/api/process/process_source.cpp
@@ -407,6 +407,7 @@ end:
     COILOG_FUNC_RETURN_RESULT(coi_result);
 }

+#if COI_LIBRARY_VERSION >= 2
 COIACCESSAPI
 COIRESULT
 SYMBOL_VERSION(COIProcessLoadLibraryFromMemory, 2)(
@@ -531,6 +532,7 @@ end:

     COILOG_FUNC_RETURN_RESULT(coi_result);
 }
+#else
 // FIXME: Symbol versioning is not supported on Windows
 COIACCESSAPI
 COIRESULT
@@ -570,7 +572,9 @@ SYMBOL_VERSION(COIProcessLoadLibraryFromMemory, 1)(

     COILOG_FUNC_RETURN_RESULT(coi_result);
 }
+#endif

+#if COI_LIBRARY_VERSION >= 2
 COIACCESSAPI
 COIRESULT
 SYMBOL_VERSION(COIProcessLoadLibraryFromFile, 2)(
@@ -625,6 +629,7 @@ end:

     COILOG_FUNC_RETURN_RESULT(coi_result);
 }
+#else
 // FIXME: Symbol versioning not supported on windows.
 COIACCESSAPI
 COIRESULT
@@ -655,6 +660,7 @@ SYMBOL_VERSION(COIProcessLoadLibraryFromFile, 1)(

     COILOG_FUNC_RETURN_RESULT(coi_result);
 }
+#endif

 COIACCESSAPI
 COIRESULT

fix the first issue, but now i get:

{standard input}: Error: invalid attempt to declare external version name as default in symbol `COIEngineGetHostname@@COI_1.0'

:/. now ive try a older gcc...

greetings

sl1pkn07 commented on 2021-01-12 01:21

fixed with

 -flto -flto-partition=none

in the CFLAGS

(https://github.com/alsa-project/alsa-lib/issues/6)

NOPE:

{standard input}: Assembler messages:
{standard input}: Error: multiple versions [`COIProcessLoadLibraryFromMemory@COI_2.0'|`COIProcessLoadLibraryFromMemory@COI_1.0'] for symbol `COIProcessLoadLibraryFromMemory'
lto-wrapper: fatal error: g++ returned 1 exit status
compilation terminated.
/usr/bin/ld: error: lto-wrapper failed
collect2: error: ld returned 1 exit status

:/

sl1pkn07 commented on 2021-01-12 00:59

$CC_FLAGS is -fPIC -O3 -D"COI_LIB_VERSION=0" -D"COI_DAEMON_ARCH=x86_64" -g -DNDEBUG -Isrc/include/ -march=native -O2 -pipe -fno-plt -I/tmp/makepkg/mpss/src/fakeroot/usr/include -DMPSS_COMMIT=\"'1f02b0c692006bd79865b0d13090c672d5dec65d'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'sl1pkn07@sL1pKn07'\" -DMPSS_BUILTON=\"'2021-01-12 01:58:29 +0100'\" -Wall -pthread -fexceptions -fstack-protector -D_FORTIFY_SOURCE=2 -D"COIHOST"
$CFLAGS is -march=native -O2 -pipe -fno-plt
$TRANSPORT_FLAGS is 
none of transport layers selected, fallback to SCIF
$CC_FLAGS is set to -fPIC -O3 -D"COI_LIB_VERSION=0" -D"COI_DAEMON_ARCH=x86_64" -g -DNDEBUG -Isrc/include/ -march=native -O2 -pipe -fno-plt -I/tmp/makepkg/mpss/src/fakeroot/usr/include -DMPSS_COMMIT=\"'1f02b0c692006bd79865b0d13090c672d5dec65d'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'sl1pkn07@sL1pKn07'\" -DMPSS_BUILTON=\"'2021-01-12 01:58:29 +0100'\" -Wall -pthread -fexceptions -fstack-protector -D_FORTIFY_SOURCE=2 -D"COIHOST" "-DTRANSPORT_SCIF"
$LD_FLAGS is set to -pthread -ldl -lrt -Wl,-z,relro,-z,now -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now "-lscif"
cc -fPIC -O3 -D"COI_LIB_VERSION=0" -D"COI_DAEMON_ARCH=x86_64" -g -DNDEBUG -Isrc/include/ -march=native -O2 -pipe -fno-plt -I/tmp/makepkg/mpss/src/fakeroot/usr/include -DMPSS_COMMIT=\"'1f02b0c692006bd79865b0d13090c672d5dec65d'\" -DMPSS_VERSION=\"'3.8.1-1'\" -DMPSS_BUILDNO=\"'0'\" -DMPSS_BUILTBY=\"'sl1pkn07@sL1pKn07'\" -DMPSS_BUILTON=\"'2021-01-12 01:58:29 +0100'\" -Wall -pthread -fexceptions -fstack-protector -D_FORTIFY_SOURCE=2 -D"COIHOST" "-DTRANSPORT_SCIF"  src/api/buffer/buffer_source.cpp -c -o build/api/buffer/buffer_source.o
{standard input}: Assembler messages:
{standard input}: Error: invalid attempt to declare external version name as default in symbol `COIEngineGetHostname@@COI_1.0'
make: *** [Makefile:406: build/api/buffer/buffer_source.o] Error 1
make: Leaving directory '/tmp/makepkg/mpss/src/mpss-coi'

i get he same error with your pkgbuild, so i test one from scratch, but i get the same resoult (the text pasted)

image28 commented on 2020-07-02 05:29

Getting closer to updating this, have some of the packages rebuilt, however I haven't finished re-writting the kernel driver. Looking into using the version from AMD's rocm driver.

image28 commented on 2020-06-15 04:44

@sl1pkn07 Working on getting a package file for 3.8.6 going. Not quite there yet

sl1pkn07 commented on 2019-03-30 20:45

this is still valid? 3.8.5 is out

this can working with Xeon Phi 5110P?

greetings

marcelhuber commented on 2016-09-12 07:06

@smotecel69:
I guess the first line of your dump is related to /etc/modprobe.d/mic.conf where options are passed to the mpss-mic module.
For me it seems that the built in mic_host module (from the kernel tree) is still loaded which shouldn't. /etc/modprobe.d/blacklist-mpss.conf should do this job by blacklisting it. Maybe there are other modules in your system which somehow depend on mic_host which you might try to blacklist too.
You might check these pages to see if you find other hints:
http://industrialinformatics.cz/xeon-phi-installation-gentoo-linux
http://arrayfire.com/getting-started-with-the-intel-xeon-phi-on-ubuntu-14-04linux-kernel-3-13-0/