Package Details: mpd-notification-git 0.8.4.r7.g3db4145-1

Git Clone URL: https://aur.archlinux.org/mpd-notification-git.git (read-only)
Package Base: mpd-notification-git
Description: Notify about tracks played by mpd - git checkout
Upstream URL: https://github.com/eworm-de/mpd-notification
Licenses: GPL
Conflicts: mpd-notification
Provides: mpd-notification
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 1
Popularity: 0.000000
First Submitted: 2014-04-30 11:54
Last Updated: 2018-05-30 10:59

Latest Comments

TrialnError commented on 2015-07-13 18:18

At least
conflicts=('mpd-notification')
should be added to the PKGBUILD.

Else on switching from the stable to the -git or vice versa fails with file conflicts

TrialnError commented on 2015-07-04 14:15

Not under that name, that's true. But the sound icon in gnome icon theme itself is just a link to audio-x-generic which is available in the adwaita icon theme. So the icon is available, just another name.

So, if I understand it correctly the icon-dep could be entirely optional?

Edit: Took a look at various icon-themes (locally installed (like nouveGnome), available from AUR4 and from the repo)
It's more likely to get a icon named audio-x-generic then one named sound. And if sound is available it's most of the times a symlink to audio-x-generic

TrialnError commented on 2015-07-04 11:01

Not under that name, that's true. But the sound icon in gnome icon theme itself is just a link to audio-x-generic which is available in the adwaita icon theme. So the icon is available, just another name.

So, if I understand it correctly the icon-dep could be entirely optional?

eworm commented on 2015-07-03 13:10

But adwaita-icon-theme does not provide a "sound" icon... So probably that is a bad idea, no?

If the icon is not available it is not displayed. In fact mpd-notification just tells the notification daemon to use an icon named "sound". Does daemon has to handle the work then.

TrialnError commented on 2015-07-03 11:01

gnome-icon-theme seems to be exchanged by adwaita-icon-theme (3.12 vs 3.16), so the dep could be adjusted?
https://bugs.archlinux.org/task/44881

And if it doesn't find a sound icon, won't it be displayed or does the program error out? If the first the icon theme could be an optdep (Thinking about users that may use dunst and don't display icons)

eworm commented on 2015-04-23 18:05

No. You can build this package and it will automatically build the latest version from git.

klaus commented on 2015-04-23 17:36

Seems like an older version than the non-git package, maybe this should be dropped?