Package Details: mpd-git 0.20.23.r1494.g901229699-2

Git Clone URL: https://aur.archlinux.org/mpd-git.git (read-only)
Package Base: mpd-git
Description: Flexible, powerful, server-side application for playing music
Upstream URL: https://www.musicpd.org/
Licenses: GPL
Conflicts: mpd
Provides: mpd
Submitter: Slash
Maintainer: E5ten (Morganamilo)
Last Packager: E5ten
Votes: 102
Popularity: 0.000001
First Submitted: 2008-09-07 18:21
Last Updated: 2018-10-29 23:25

Required by (28)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

broken.pipe commented on 2013-07-13 07:56

missing dependency: yajl

misc commented on 2013-06-18 09:36

Until this is fixed in mpd, you're going to need something like this with ffmpeg-git:

sed '1i\
#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000' -i src/decoder/FfmpegDecoderPlugin.cxx

That's also the workaround the mplayer devs used, though they may have come up with a proper replacement by now.

jdevelop commented on 2013-05-17 18:42

If using ffmpeg-git, it is not possible to build mpd:

g++ -DHAVE_CONFIG_H -I. -DNDEBUG -I./src -pthread -isystem /usr/include/glib-2.0 -isystem /usr/lib/glib-2.0/include -DSYSTEM_CONFIG_FIL
E_LOCATION='"/etc/mpd.conf"' -I/usr/include -I/usr/include/opus -std=gnu++0x -march=x86-64 -mtune=generic -O2 -pipe -f
stack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -ffunction-sections -fdata-sections -fvisibility=hidden -fno-threadsafe-st
atics -fmerge-all-constants -fno-exceptions -fno-rtti -Wall -Wextra -Wmissing-declarations -Wshadow -Wpointer-arith -Wcast-qual -Wwrite-
strings -Wsign-compare -MT src/decoder/libdecoder_plugins_a-FfmpegDecoderPlugin.o -MD -MP -MF src/decoder/.deps/libdecoder_plugins_a-Ffm
pegDecoderPlugin.Tpo -c -o src/decoder/libdecoder_plugins_a-FfmpegDecoderPlugin.o `test -f 'src/decoder/FfmpegDecoderPlugin.cxx' || echo
'./'`src/decoder/FfmpegDecoderPlugin.cxx
src/decoder/FfmpegDecoderPlugin.cxx: In function ‘decoder_command ffmpeg_send_packet(decoder*, input_stream*, const AVPacket*, AVCodecCo
ntext*, const AVRational*, AVFrame*)’:
src/decoder/FfmpegDecoderPlugin.cxx:283:26: error: ‘AVCODEC_MAX_AUDIO_FRAME_SIZE’ was not declared in this scope
uint8_t aligned_buffer[(AVCODEC_MAX_AUDIO_FRAME_SIZE * 3) / 2 + 16];
^
src/decoder/FfmpegDecoderPlugin.cxx:284:36: error: ‘aligned_buffer’ was not declared in this scope
const size_t buffer_size = sizeof(aligned_buffer);
^
make[1]: *** [src/decoder/libdecoder_plugins_a-FfmpegDecoderPlugin.o] Error 1
make[1]: Leaving directory `/usr/aur/srcpackages/mpd-git/src/mpd-git'

For the moment I fixed the problem with adding disable-ffmpeg to build script.

sudokode commented on 2013-04-20 22:54

Done. Also removing that ugly epoch. Ignore the downgrade warning.

Rasi commented on 2013-04-20 21:03

lastfm support is deprecated, please remove it

sudokode commented on 2013-04-08 00:59

Updated for the new makepkg.

sudokode commented on 2013-02-12 22:47

Removed the sysvinit script.

sudokode commented on 2013-01-22 21:19

No idea why they haven't fixed this upstream yet. Looks like they're converting everything to C++? The patch below won't work because of this. There's a patch included now and should be applied automagically.

ianux commented on 2013-01-20 00:12

Here is the patch for libcdio-paranoia: http://dl.free.fr/rpFkWrXKn
sha256sum: 90e827a1d24a5739d7e6867c8fee6d58b8d449fe3e3c40b7732cadc06008d5aa

The lines
# patch for libcdio-paranoia
patch -p0 -i ${srcdir}/libcdio-paranoia.patch

should be added to the PKGBUILD file before the line
# Configure Source

ianux commented on 2013-01-20 00:07

Here is the patch for libcdio-paranoia: http://dl.free.fr/rpFkWrXKn
md5sum: bceeec493c4eb8e57e21b480d9ef009e

The lines
# patch for libcdio-paranoia
patch -p0 -i ${srcdir}/libcdio-paranoia.patch

should be added to the PKGBUILD file before the line
# Configure Source