Package Details: mpd-git 0.20.23.r1494.g901229699-2

Git Clone URL: https://aur.archlinux.org/mpd-git.git (read-only)
Package Base: mpd-git
Description: Flexible, powerful, server-side application for playing music
Upstream URL: https://www.musicpd.org/
Licenses: GPL
Conflicts: mpd
Provides: mpd
Submitter: Slash
Maintainer: E5ten (Morganamilo)
Last Packager: E5ten
Votes: 102
Popularity: 0.000001
First Submitted: 2008-09-07 18:21
Last Updated: 2018-10-29 23:25

Required by (28)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

sudokode commented on 2014-10-21 21:15

Okay. Not sure if --disable-aac removes the faad2 dep. I don't have a clean build environment at the moment.

iffer commented on 2014-10-21 20:56

Please update the pkgver to 0.19.1 and add --disable-aac to the configure-lines:

./configure \
… \
--disable-aac
make


See this thread for more info about the problem with aac:
https://bbs.archlinux.org/viewtopic.php?pid=1468312

iffer commented on 2014-10-21 20:51

Please update the pkgver to 0.19.1 and add --disable-aac to the configure-lines:

./configure \
… \
--disable-aac
make

Tomaash commented on 2014-09-22 08:44

There may be, and that's the reason it should provide mpd.

sudokode commented on 2014-09-14 16:19

Fixed the version issue.

Why does mpd-git have to provide mpd? That's only required when something is a dependency. Is there such a scenario?

flu commented on 2014-09-10 15:10

"v" pkgver prefix makes my AUR helper ask me to update every time. Could you strip it, please? Like ;s/^v//g

Dietr1ch commented on 2014-08-26 12:50

This should also provide mpd

blackhole commented on 2014-07-01 07:47

Now build fine with libnfs 1.9.4-1!

blackhole commented on 2014-06-23 08:35

The problem persists also with libnfs-git.
There is something wrong about Connection.cxx in /aur-mpd-git/src/mpd-git/src/lib/nfs/

------------
src/lib/nfs/Connection.cxx:112:9: error: ‘POLLOUT’ was not declared in this scope
((i & POLLOUT) ? SocketMonitor::WRITE : 0);
^
src/lib/nfs/Connection.cxx:113:1: error: body of constexpr function ‘constexpr unsigned int libnfs_to_events(int)’ not a return-statement
}
^
src/lib/nfs/Connection.cxx: In function ‘constexpr int events_to_libnfs(unsigned int)’:
src/lib/nfs/Connection.cxx:118:38: error: ‘POLLIN’ was not declared in this scope
return ((i & SocketMonitor::READ) ? POLLIN : 0) |
^
src/lib/nfs/Connection.cxx:119:33: error: ‘POLLOUT’ was not declared in this scope
((i & SocketMonitor::WRITE) ? POLLOUT : 0);
^
src/lib/nfs/Connection.cxx:120:1: error: body of constexpr function ‘constexpr int events_to_libnfs(unsigned int)’ not a return-statement
}
^
src/lib/nfs/Connection.cxx: In function ‘constexpr unsigned int libnfs_to_events(int)’:
src/lib/nfs/Connection.cxx:113:1: warning: control reaches end of non-void function [-Wreturn-type]
}
^
src/lib/nfs/Connection.cxx: In function ‘constexpr int events_to_libnfs(unsigned int)’:
src/lib/nfs/Connection.cxx:120:1: warning: control reaches end of non-void function [-Wreturn-type]
}

blackhole commented on 2014-06-22 06:37

Same problem as before. Do I need libnfs-git?