Package Details: mopidy-spotify 4.0.1-1

Git Clone URL: https://aur.archlinux.org/mopidy-spotify.git (read-only, click to copy)
Package Base: mopidy-spotify
Description: Mopidy extension for playing music from Spotify
Upstream URL: http://www.mopidy.com
Licenses: Apache
Submitter: AlexandrePTJ
Maintainer: fmauNeko
Last Packager: fmauNeko
Votes: 88
Popularity: 0.51
First Submitted: 2013-10-28 13:24
Last Updated: 2020-01-22 10:05

Latest Comments

1 2 Next › Last »

MarcinWieczorek commented on 2019-12-30 18:52

I've tweaked @languitar's PKGBUILD. Seems to be working on mopidy 3.

diff --git a/PKGBUILD b/PKGBUILD
index b9649ea..2a65b30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,19 @@
 # Maintainer: Alexandre Petitjean <alpetitjean at gmail dot com>

 pkgname=mopidy-spotify
-pkgver=3.1.0
+pkgver=4.0.0
 pkgrel=1
 pkgdesc="Mopidy extension for playing music from Spotify"
 arch=('any')
 url="http://www.mopidy.com"
 license=('APACHE')
-depends=(
-    'mopidy>=2'
-    'python2-pykka>=1.1'
-    'python2-pyspotify>=2'
-    'python2-setuptools'
-    'python2-requests>=2')
-makedepends=('python2')
-provides=('mopidy-spotify')
-source=("https://github.com/mopidy/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('2fa4827b72c627b9d10ee10a5e5d7961')
+depends=('mopidy>=3' python-pykka python-pyspotify python-setuptools python-requests)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mopidy/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('2c71e65fbaf6a23a0e506da25095ba7e')

 package() {
   cd "$srcdir/$pkgname-$pkgver"
-  python2 setup.py install --root="$pkgdir/" --optimize=1
+  python3 setup.py install --root="$pkgdir/" --optimize=1
 }

 # vim:set ts=2 sw=2 et:

languitar commented on 2019-12-23 13:29

Here is an updated PKGBUILD which I am using myself right now: https://gist.github.com/languitar/59dd55ca7454ca88c11ade8a5a47ca0b

languitar commented on 2019-12-23 13:03

Any chance to get this updated to 4.0 to get mopidy 3.0 support?

annata83 commented on 2018-12-05 04:05

Hi there, I would like some help to figure this out. I clone https://aur.archlinux.org/mopidy-spotify.git and makepkg -si with an error of: pacman fail to install missing dependencies.

Already have: python2-setuptools 1:40.6 python2-pykka 1.2.1 ( can I use this version?) mopidy 2.2.1 (do I need mopidy-git to?) python2-requests 2.20 (can I use this version?) python2 2.7.15

Don't have: AUR packages!! python2-pyspotify python2-requests-git *stackless-python2

weaner commented on 2017-06-09 22:54

Unable to play songs from Spotify via Iris after the 3.1.0-1 upgrade.
Can search Spotify as normal but when I try to play any track I get a "Failed to add some URI(s)"error.
Works as expected when downgraded to the previous release.

Forty-Bot commented on 2016-12-16 19:07

Line 13

'python2-pyspotify>=2'

should be changed to

'python2-spotify>=2'

milouse commented on 2015-09-23 12:45

Woops... I don't mean to flag out of date this package... Sorry for the spam. I wanted to flag python2-pyspotify. Wrong tab. :(

AlexandrePTJ commented on 2015-08-14 07:40

As there a change in dependency requirement, it should need to uninstall mopidy-spotify first and then re-install.

AlexandrePTJ commented on 2014-12-29 09:05

I don't really know. It is from the Debian branch, so not related for Archlinux.
Usually I take the master branch to follow new versions.

mittens2001 commented on 2014-12-29 01:56

woops, sorry about that. what is this? https://github.com/mopidy/mopidy-spotify/releases/tag/debian%2F1.2.0-0mopidy2