Package Details: mopidy-gmusic-git 4.0.0.r0.g88e71a1-1

Git Clone URL: https://aur.archlinux.org/mopidy-gmusic-git.git (read-only, click to copy)
Package Base: mopidy-gmusic-git
Description: Mopidy extension for playing music from Google Play Music
Upstream URL: https://github.com/mopidy/mopidy-gmusic
Keywords: gmusic mopidy
Licenses: Apache
Conflicts: mopidy-gmusic
Provides: mopidy-gmusic
Submitter: rob-alexander
Maintainer: sicariusnoctis
Last Packager: sicariusnoctis
Votes: 3
Popularity: 0.000000
First Submitted: 2015-10-16 20:38
Last Updated: 2020-02-10 11:58

Latest Comments

sicariusnoctis commented on 2020-01-22 02:34

This package is out of date. Those python2-* packages do not exist anymore. Luckily, mopidy-gmusic 4.0 is intended to be run on python 3 anyways. :)

Here's a corrected PKGBUILD:

_pkgname=mopidy-gmusic
pkgname=${_pkgname}-git
pkgver=4.0.0.r0.g88e71a1
pkgrel=1
pkgdesc="Mopidy extension for playing music from Google Play Music"
arch=('any')
url="https://github.com/mopidy/mopidy-gmusic"
license=('APACHE')
depends=(
    'mopidy'
    'python'
    'python-cachetools'
    'python-gmusicapi'
    'python-pykka'
    'python-requests'
)
makedepends=('python-setuptools' 'git')
provides=(${_pkgname})
conflicts=(${_pkgname})
options=(!emptydirs)
source=("${_pkgname}::git+https://github.com/mopidy/mopidy-gmusic.git")
md5sums=('SKIP')

pkgver() {
    cd "${srcdir}/${_pkgname}"
    git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}

package() {
    cd "${srcdir}/${_pkgname}"
    python setup.py install --root="${pkgdir}" --optimize=1
}

MarcinWieczorek commented on 2019-12-30 19:38

@yubimusubi try updating basing on the non-git package

yubimusubi commented on 2016-11-07 22:42

This package won't actually work until python2-gpsoauth is updated to 0.4.0 ... This has been added as a dependency in the latest update. In the meantime, it will break the build process due to unresolved dependencies (IMO this explicit failure is better than the current behavior of quietly disabling itself at runtime).

rob-alexander commented on 2016-10-27 17:22

I no longer use this pkgbuild and have disowned it. Feel free to pick it up!

RazZziel commented on 2016-10-08 09:27

Lacks dependencies python2-cachetools, python2-gmusicapi-git and python2-pycryptodomex:
> INFO Disabled extension gmusic: Dependency The 'cachetools>=1.0' distribution was not found and is required by the application not found
> INFO Disabled extension gmusic: gmusicapi>=10.0 required, but found gmusicapi 9.0.0 at /usr/lib/python2.7/site-packages
> INFO Disabled extension gmusic: Dependency The 'pycryptodome>=3.0' distribution was not found and is required by gpsoauth not found

Last dependency doesn't seem to be fixed after installing python2-pycryptodomex though