Package Details: moonscript 0.5.0_1-1

Git Clone URL: https://aur.archlinux.org/moonscript.git (read-only, click to copy)
Package Base: moonscript
Description: A programmer friendly language that compiles to Lua
Upstream URL: http://moonscript.org
Licenses: MIT
Submitter: xyproto
Maintainer: caleb
Last Packager: jahiy
Votes: 8
Popularity: 0.000000
First Submitted: 2011-08-11 12:49
Last Updated: 2016-11-04 11:51

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

xyproto commented on 2014-01-18 15:39

Thanks for noticing, Shoozza. Will fix.

Shoozza commented on 2014-01-17 23:37

reference.md sha wrong again
also cannot remove 5.1/re.lua
and chmod lua/5.1/ dir does not exist
it seems to use lua 5.2 now

sl1pkn07 commented on 2014-01-02 23:12

conflicts with lua51-filesystem

xyproto commented on 2013-12-29 22:06

Thanks Shoozza, updated the checksums.

Shoozza commented on 2013-12-26 04:05

reference.md has a wrong sha

andreas_baumann commented on 2013-09-21 19:31

I get:

error: failed to commit transaction (conflicting files)
moonscript: /usr/lib/lua/5.1/lpeg.so exists in filesystem
moonscript: /usr/lib/luarocks/rocks/lpeg/0.12-1/lpeg-0.12-1.rockspec exists in filesystem
moonscript: /usr/lib/luarocks/rocks/lpeg/0.12-1/rock_manifest exists in filesystem
moonscript: /usr/lib/luarocks/rocks/manifest exists in filesystem
Errors occurred, no packages were upgraded.

The checksum changed too.

xyproto commented on 2013-04-01 19:07

Thanks, EisenSheng. Updated the package.

EisenSheng commented on 2013-04-01 13:22

it seems luafilesystem was renamed to lua-filesystem

xyproto commented on 2013-03-27 11:31

luafilesystem seems to have disappeared. I will have to add it before updating this package.

xyproto commented on 2011-08-16 14:31

Added make dependency on git.