Package Details: mono-git 6.10.0.95.r761.8248c906564-1

Git Clone URL: https://aur.archlinux.org/mono-git.git (read-only, click to copy)
Package Base: mono-git
Description: Free implementation of the .NET platform including runtime and compiler
Upstream URL: http://www.mono-project.com/
Keywords: mono
Licenses: GPL, BSD, MPL, LGPL2.1, custom=MITX11, custom=MSPL
Conflicts: mono, monodoc
Provides: mono=${pkgver}, monodoc
Submitter: Ziemas
Maintainer: FabioLolix (hugegameartgd)
Last Packager: hugegameartgd
Votes: 13
Popularity: 0.000000
First Submitted: 2011-03-25 16:52
Last Updated: 2020-03-14 15:37

Required by (293)

Sources (24)

Latest Comments

« First ‹ Previous 1 2 3 4

lpjhjdh commented on 2013-05-13 21:09

I don't have time to figure the actual problem and a proper fix but if anyone else has arm issues with mono/mini: to get things to compile I needed to explicitly call the arm_dpimacros.h target, modifying the PKGBUILD with

./autogen.sh --prefix=/usr --sysconfdir=/etc \
--with-libgdiplus=installed
(cd mono/arch/arm && make arm_dpimacros.h)
make || return

and to apply the following patch

diff --git a/mono/mini/aot-runtime.c b/mono/mini/aot-runtime.c
index 730fb4a..ace0c41 100644
--- a/mono/mini/aot-runtime.c
+++ b/mono/mini/aot-runtime.c
@@ -55,6 +55,8 @@
#include "mono/utils/mono-compiler.h"
#include <mono/utils/mono-counters.h>

+#include <mono/arch/arm/arm-codegen.h>
+
#include "mini.h"
#include "version.h"

giniu commented on 2013-01-08 22:46

They were very quick, the fix is already here: https://github.com/mono/mono/commit/052ba601f3ed9e7fc5a216407986a89ee0c3296f

Ziemas commented on 2013-01-07 20:21

The options are to either have Mono installed already or to download Monolite in order to get a working mcs.

I don't really know anything about how automake works, if you have a solution i could add it or hand you over maintainership of the package. Or we could wait until they fix it.

giniu commented on 2013-01-07 16:43

hmm... is mono really rquired to build mono-git? Also, please check your build - it seems that mono no longer builds with Arch provided automake/autoconf - you need to make some configure.in substitutions and Makefile.am commenting.