Package Details: mono-git 5.18.0.225.r1530.d1a5fa3783b-1

Git Clone URL: https://aur.archlinux.org/mono-git.git (read-only, click to copy)
Package Base: mono-git
Description: Free implementation of the .NET platform including runtime and compiler
Upstream URL: http://www.mono-project.com/
Keywords: mono
Licenses: GPL, BSD, MPL, LGPL2.1, custom=MITX11, custom=MSPL
Conflicts: mono, monodoc
Provides: mono, monodoc
Submitter: Ziemas
Maintainer: FabioLolix (hugegameartgd)
Last Packager: devopsdeluxe
Votes: 13
Popularity: 0.000000
First Submitted: 2011-03-25 16:52
Last Updated: 2018-12-27 20:41

Required by (293)

Sources (23)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

urbanomad64 commented on 2014-04-19 07:01

would you fix the git repository and mono stable is at version 3.4 now

Twl commented on 2013-10-19 08:45

Adopted and bumped version provided to 3.2.0

Let me know if you have any issues.

Ziemas commented on 2013-10-19 08:16

I've decided to disown this package. I no longer have any use case for using mono from git. And no interested in maintaining this package.

monojp commented on 2013-09-11 08:04

does anyone know a repo which provides this or any other more current mono build than found in extra? Compiling myself may be possible but it takes very long and uses up most of my disk-space in /tmp

Ziemas commented on 2013-07-13 19:26

Now providing mono=3.1.0 as requested.

weltall commented on 2013-07-13 13:51

It would be nice if it was possible to add the mono version in provides (mono=3.1.0), because as of now pacman complains that it cannot find mono >= 2.10.8 when installing packages from the extra repo (e.g. monodevelop)

Anonymous comment on 2013-07-03 07:38

I had to install libtool, but it isn't listed as a dep.

Ziemas commented on 2013-06-21 13:49

PKGBUILD has been updated for makepkg's VCS support.

earlz commented on 2013-05-26 02:45

@lpjhjdh: I can confirm that it's broken, but that didn't fix it for me on Raspberry Pi

lpjhjdh commented on 2013-05-13 21:09

I don't have time to figure the actual problem and a proper fix but if anyone else has arm issues with mono/mini: to get things to compile I needed to explicitly call the arm_dpimacros.h target, modifying the PKGBUILD with

./autogen.sh --prefix=/usr --sysconfdir=/etc \
--with-libgdiplus=installed
(cd mono/arch/arm && make arm_dpimacros.h)
make || return

and to apply the following patch

diff --git a/mono/mini/aot-runtime.c b/mono/mini/aot-runtime.c
index 730fb4a..ace0c41 100644
--- a/mono/mini/aot-runtime.c
+++ b/mono/mini/aot-runtime.c
@@ -55,6 +55,8 @@
#include "mono/utils/mono-compiler.h"
#include <mono/utils/mono-counters.h>

+#include <mono/arch/arm/arm-codegen.h>
+
#include "mini.h"
#include "version.h"