Package Details: mono-git 6.10.0.95.r761.8248c906564-1

Git Clone URL: https://aur.archlinux.org/mono-git.git (read-only, click to copy)
Package Base: mono-git
Description: Free implementation of the .NET platform including runtime and compiler
Upstream URL: http://www.mono-project.com/
Keywords: mono
Licenses: GPL, BSD, MPL, LGPL2.1, custom=MITX11, custom=MSPL
Conflicts: mono, monodoc
Provides: mono=${pkgver}, monodoc
Submitter: Ziemas
Maintainer: FabioLolix (hugegameartgd)
Last Packager: hugegameartgd
Votes: 13
Popularity: 0.000000
First Submitted: 2011-03-25 16:52
Last Updated: 2020-03-14 15:37

Required by (293)

Sources (24)

Latest Comments

1 2 3 4 Next › Last »

hugegameartgd commented on 2020-03-14 15:49

@FabioLolix Thanks for adding me as co-maintainer, I tried to contact you but now just pushed the diff below and some second fix. Last patch in provides ensures that msbuild-git detects correct version of mono. Not sure how it should correctly look like in .srcinfo though.

hugegameartgd commented on 2019-12-18 17:28

@RononDex

diff --git a/PKGBUILD b/PKGBUILD
index cb8a9f3..71b1560 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@

 pkgname='mono-git'
 _gitname='mono'
-pkgver=5.18.0.225.r1530.d1a5fa3783b
+pkgver=6.6.0.161.r1685.ff6294d2311
 pkgrel=1
 pkgdesc='Free implementation of the .NET platform including runtime and compiler'
 url='http://www.mono-project.com/'
@@ -36,13 +36,14 @@ source=(
   'git+https://github.com/mono/xunit-binaries.git'
   'git+https://github.com/mono/api-doc-tools.git'
   'git+https://github.com/mono/api-snapshot.git'
-  'git+https://github.com/mono/llvm.git#branch=release_60'
+  'git+https://github.com/dotnet/llvm-project.git'
   'git+https://github.com/mono/helix-binaries.git'
+  'git+https://github.com/Unity-Technologies/bdwgc.git'
   'mono.binfmt.d'
 )
 sha256sums=(
   'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
-  'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+  'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
   '9a657fc153ef4ce23bf5fc369a26bf4a124e9304bde3744d04c583c54ca47425'
 )

@@ -80,8 +81,9 @@ prepare() {
     'xunit-binaries'
     'api-doc-tools'
     'api-snapshot'
-    'llvm'
+    'llvm-project'
     'helix-binaries'
+    'bdwgc'
   )

   for module in "${submodules[@]}"; do
@@ -139,12 +141,12 @@ package() {

   # Fix .pc file to be able to request mono on what it depends, fixes
   # go-oo build:
-  sed -i -e           \
-    "s:/2.0/:/4.5/:g" \
-    "${pkgdir}/usr/lib/pkgconfig/mono-nunit.pc"
-  sed -i -e                 \
-    "s:#Requires:Requires:" \
-    "${pkgdir}/usr/lib/pkgconfig/mono.pc"
+  #sed -i -e           \
+    #"s:/2.0/:/4.5/:g" \
+    #"${pkgdir}/usr/lib/pkgconfig/mono-nunit.pc"
+  #sed -i -e                 \
+    #"s:#Requires:Requires:" \
+    #"${pkgdir}/usr/lib/pkgconfig/mono.pc"
 }

 # vim: ts=2 sw=2 et:

RononDex commented on 2019-11-26 08:43

I keep getting this error when trying to build this package: error: pathspec 'external/llvm' did not match any file(s) known to git

PedroHLC commented on 2019-08-29 12:30

@hugegameartgd for now, delete that line...

hugegameartgd commented on 2019-08-28 15:03

@PedroHLC I get the same error. Is there any fix available?

PedroHLC commented on 2019-08-22 12:23

sed: can't read /home/main-builder/pkgwork/pkg/mono-git/usr/lib/pkgconfig/mono-nunit.pc: No such file or directory

In extra they don't seem to do these seds, are they really necessary?

poikilos commented on 2017-12-08 21:28

It turns out to be an upstream problem. I posted my specs (in a later comment) and the full info here: https://github.com/mono/mono/issues/6197 A fix is being merged, but make still assumes default python is python2 (when using the version here https://github.com/lewurm/mono.git being merged), resulting in a different big list of errors: https://github.com/mono/mono/issues/6204

devopsdeluxe commented on 2017-12-05 20:47

@axlemedia

Can I get your system specs?

I'm unable to reproduce the issue on my laptop and desktop.

poikilos commented on 2017-12-05 19:46

Build fails with native stacktrace (after "CSC [basic] ilasm.exe" then tons of "Instruction metadata for * inconsistent." errors, where * is iconst and fill_prof_call_ctx and other things), on updated (2017-12-03) system. Then it said gdb missing so I installed gdb and built again so that I could get the full debug info: https://pastebin.com/yM5B5MdJ

devopsdeluxe commented on 2017-01-06 18:15

Mono is now successfully building on my machines again.

I'll be updating the PKGUILD shortly!