Package Details: mojave-gtk-theme 2020_03_24-1

Git Clone URL: https://aur.archlinux.org/mojave-gtk-theme.git (read-only, click to copy)
Package Base: mojave-gtk-theme
Description: A Mac OSX like theme for GTK 3, GTK 2 and Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments like Gnome, Pantheon, XFCE, Mate, etc.
Upstream URL: https://github.com/vinceliuice/Mojave-gtk-theme
Keywords: gtk theme
Licenses: GPL3
Conflicts: mojave-gtk-theme-git
Submitter: thomasqueirozb
Maintainer: thomasqueirozb (spsf64)
Last Packager: spsf64
Votes: 2
Popularity: 0.94
First Submitted: 2019-09-14 21:51
Last Updated: 2020-04-02 22:26

Latest Comments

spsf64 commented on 2020-04-02 22:36

@ValHue, package updated, thanks for your contribution!

ValHue commented on 2020-03-24 16:48

The release version is now fixed. Now the latest version available is 2020_03_24 and here https://pastebin.com/b3qix5Dr is the PKGBUILD checked and working.

ValHue commented on 2020-03-24 11:33

@pschyma The problem is in the release version. If the git version is compiled it does not fail. It will have to be communicated to the developer.

pschyma commented on 2020-03-23 21:40

@ValHue the 2020-03-19 release should be affected by https://github.com/vinceliuice/Mojave-gtk-theme/issues/121

ValHue commented on 2020-03-23 15:02

@thomasqueirozb not much change is necessary. The question is to update this line:

makedepends=('sassc' 'optipng' 'inkscape')

It is also necessary to uncomment:

options=('!strip')

Now it does compile the new version


The problem in my case is that the package it generates weighs a lot and when I log in, my desktop hangs. I think it is a bug. Don't update for now.

thomasqueirozb commented on 2020-03-23 00:08

These changes were added to the PKGBUILD. Thank you for pointing my mistakes out @kendfinger and @dmitmel. I'm kinda new to the AUR and didn't even know about namcap and I will be sure to keep it in mind the next time I package something.

spsf64 commented on 2020-03-22 20:34

@dmitmel and @kendfinger; thanks for your contributions! I tried to build the latest version and it takes forever... I will contact Thomas, he will probably sort this out.

dmitmel commented on 2020-03-21 09:24

Continuing work done by @kendfinger, I also added all dependencies to makedepends. Here's the full patch:

diff --git a/PKGBUILD b/PKGBUILD
index 27b8ad5..2f07e23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer Thomas Queiroz <thomasqueirozb@gmail.com>
+# Maintainer: Thomas Queiroz <thomasqueirozb@gmail.com>
 # Contributor: Sergio Schneider <spsf1964@gmail.com>

 pkgname=mojave-gtk-theme
 _pkgname=Mojave-gtk-theme
 pkgver=2020_02_20
-pkgrel=1
+pkgrel=2
 pkgdesc='A Mac OSX like theme for GTK 3, GTK 2 and Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments like Gnome, Pantheon, XFCE, Mate, etc.'
 arch=('any')
 depends=('gtk3' 'gtk-engine-murrine' 'gtk-engines')
 license=('GPL3')
 url='https://github.com/vinceliuice/Mojave-gtk-theme'
-source=("https://github.com/vinceliuice/${_pkgname}/archive/${pkgver//_/-}.tar.gz")
-md5sums=('5fb90ac9bd7155f8f51f5814012691bf')
-makedepends=('git')
+source=("${pkgname}-${pkgver//_/-}.tar.gz::https://github.com/vinceliuice/${_pkgname}/archive/${pkgver//_/-}.tar.gz")
+sha512sums=('367b72adca4b07696167624ec649a9a134170cf8fb2e9f76c07cee7b15d6b06c7c55946d0cc21b31f14e02dcec19dd990afba4e5d839631e1150bfd699912521')
+makedepends=('git' 'sassc' 'optipng' 'inkscape')
 # options=('!strip')
 conflicts=('mojave-gtk-theme-git')

@@ -21,5 +21,5 @@ package() {
    install -m755 -d "${pkgdir}/usr/share/themes"
    ./install.sh \
         --dest "${pkgdir}/usr/share/themes" \
-        --icon arch 
+        --icon arch
 }

By the way, does anyone have any idea why version 2020-03-19 fails to compile? On my machine it starts eating RAM like crazy and eventually runs out of it without any progress.

P.S. I don't think SHA-512 is strictly necessary in this case.

kendfinger commented on 2020-03-20 13:06

Hi @spsf64 and @thomasqueirozb

I have made a patch at https://gist.github.com/kendfinger/0536f82877bde9a6ac137ce2b6f112f3 that makes this package conform to the namcap standards. namcap is the linter for PKGBUILDs and is available in [extra]