Package Details: mod_perl 2.0.11-1

Git Clone URL: https://aur.archlinux.org/mod_perl.git (read-only)
Package Base: mod_perl
Description: Apache module that embeds the Perl interpreter within the server
Upstream URL: http://perl.apache.org/
Licenses: Apache
Submitter: anatolik
Maintainer: mattsday
Last Packager: mattsday
Votes: 7
Popularity: 1.34
First Submitted: 2015-06-28 15:38
Last Updated: 2019-11-06 08:32

Pinned Comments

lb.laboon commented on 2017-09-14 16:24

A note to everyone compiling this package:

You must import PGP key AB34BA0040E92ECE into your keyring in order to validate the source package.
Please see the Arch wiki for more details: https://wiki.archlinux.org/index.php/makepkg#Signature_checking

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

ArthurBorsboom commented on 2016-01-31 09:03

==> Validating source files with sha256sums...
mod_perl-2.0.9.tar.gz ... Passed
mod_perl-2.0.9.tar.gz.asc ... Skipped
undefined_symbol.patch ... Passed
perl_522.patch ... Passed
==> Verifying source file signatures with gpg...
mod_perl-2.0.9.tar.gz ... FAILED (unknown public key AB34BA0040E92ECE)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build mod_perl.

lb.laboon commented on 2016-01-30 21:17

Confirmed working on my system as well!

anatolik commented on 2016-01-30 18:55

Thanks for headsup.

I added the patch to this package. Now I can start apache with mod_perl and perl 5.22. Yay!

Please test it carefully and report upstream if there are any issues.

Thanks for your help!!

Alex_5252 commented on 2016-01-30 18:22

The description Bug #101962 link https://rt.cpan.org/Public/Bug/Display.html?id=101962 published patch Perl-5.22-compatibility-take-4.patch, which fixed the problem of falls.
Check it out, please?

lb.laboon commented on 2015-12-20 16:35

@nelsinchi
mod_perl won't work with the latest version of perl. If you are replacing the 'perl<5.22' dependency with 'perl' then the package will build successfully, but it won't work when you try to run it (i.e. with Apache). The only way for it to work is to install perl 5.20 or lower, but it is no longer in the repositories. You will have to compile it from source yourself.

nelsinchi commented on 2015-12-20 14:06

@ArthurBorsboom: Thanks a lot for your support! I was configuring BackupPC and by doing this I was needing to install mod_perl.

I found the 2 errors and I followed what you said and it works.

Just one more thing, when I add "LoadModule perl_module modules/mod_perl.so" into my httpd.conf, the service does not run.

Thanks.

lb.laboon commented on 2015-11-25 18:24

According to the bug thread, it looks like they have a fix which will be implemented in version 2.0.10 pretty soon. When that happens, will this package move back to the official repos or is it going to stay in the AUR?

https://rt.cpan.org/Public/Bug/Display.html?id=101962

anatolik commented on 2015-09-01 17:28

Besides downgrading perl you have 2 more options:

- The best option is to avoid using mod_perl. mod_perl development is in stagnation nowdays.

- Contact upstream and ask to fix Perl 5.22 issues.

lclc commented on 2015-09-01 14:37

I downgraded my Perl version (and a few packages depending on v5.22) to work around this for now (so far no negative side effects):

cd /var/cache/pacman/pkg/
sudo pacman -U perl-5.20.2-1-x86_64.pkg.tar.xz perl-dbd-mysql-4.031-1-x86_64.pkg.tar.xz perl-dbi-1.633-1-x86_64.pkg.tar.xz perl-linux-pid-0.04-4-x86_64.pkg.tar.xz perl-xml-libxml-2.0121-1-x86_64.pkg.tar.xz perl-xml-parser-2.44-1-x86_64.pkg.tar.xz

Very annoying.

loserMcloser commented on 2015-08-15 17:15

@ArthurBorsboom

Straight from the mod_perl v2.0.9 announce mail (fourth message from the bottom at http://mail-archives.apache.org/mod_mbox/perl-modperl/201506.mbox/browser):

"Note that Perl 5.22.x is currently not supported. This is logged as
CPAN RT#101962 and will hopefully be addressed in 2.0.10."