Package Details: moarvm 2021.07-1

Git Clone URL: https://aur.archlinux.org/moarvm.git (read-only, click to copy)
Package Base: moarvm
Description: A VM with adaptive optimization and JIT compilation, built for Rakudo
Upstream URL: http://moarvm.com/
Licenses: PerlArtistic
Submitter: spider-mario
Maintainer: spider-mario
Last Packager: spider-mario
Votes: 31
Popularity: 0.009580
First Submitted: 2014-02-05 20:38
Last Updated: 2021-07-25 19:09

Latest Comments

spider-mario commented on 2021-03-03 23:58

Yes, that’s what I meant. It indeed won’t run if it was built with it and it’s missing at runtime.

jonathon commented on 2021-03-02 12:37

Something like this:

makedepends=(zstd)
optdepends=('zstd: Support for zstd compression')

would work for an optional dependency required at build time, assuming MoarVM will actually run without zstd being compiled in but not present at runtime. If it won't run then it's a plain depends.

spider-mario commented on 2020-12-20 08:46

My understanding of optdepends is that it’s supposed to be for packages that are optional at runtime, given the package that has been built. Since zstd is an indirect dependency of pacman, most people will likely build the package with zstd installed, and in this case, the package depends non-optionally on it.

To my knowledge, makepkg doesn’t really have a mechanism to facilitate this sort of dependency that is optional at build time but becomes mandatory at runtime if it was there at build time.

MasterDuke commented on 2020-12-19 20:46

FYI, zstd is only an optional dependency of MoarVM.