Package Details: mnamer 2.5.2-1

Git Clone URL: https://aur.archlinux.org/mnamer.git (read-only, click to copy)
Package Base: mnamer
Description: A media organization tool
Upstream URL: https://github.com/jkwill87/mnamer
Keywords: batch cli media metadata movie organizer python television
Licenses: MIT
Submitter: ragouel
Maintainer: None
Last Packager: ragouel
Votes: 2
Popularity: 0.22
First Submitted: 2020-05-07 07:59
Last Updated: 2021-01-16 00:19

Latest Comments

ragouel commented on 2021-01-16 00:36

Fixed.

hubnerd commented on 2021-01-06 10:40

Not working currently as requirements.txt requires guessit dep version as 3.1. Current version of guessit on aur is 3.2.

jkwill87 commented on 2021-01-06 07:04

mnmaer dev here.

This may be due to Arch's recent update from Python 3.8 to Python 3.9. Other AUR Python packages have reported similar breakages elsewhere on the internet. I suspect that you may some dependencies installed with Python 3.9 and other from the AUR using Python 3.8. If this is the case perhaps uninstalling and reinstalling the listed dependencies may sort out the issue? Sorry, I'm not the maintainer for this package and don't currently use Arch so I can't confirm whether this is the case.

gnacho commented on 2021-01-03 22:20

It's not working after last update. python-guessit seems to be the problem.

$ mnamer
Traceback (most recent call last):
  File "/usr/bin/mnamer", line 33, in <module>
    sys.exit(load_entry_point('mnamer==2.4.2', 'console_scripts', 'mnamer')())
  File "/usr/bin/mnamer", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: mnamer