Package Details: mkdocs 1.0.4-1

Git Clone URL: https://aur.archlinux.org/mkdocs.git (read-only, click to copy)
Package Base: mkdocs
Description: Project documentation with Markdown.
Upstream URL: http://www.mkdocs.org
Licenses: BSD
Submitter: None
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 17
Popularity: 0.024740
First Submitted: 2015-06-11 18:21
Last Updated: 2018-10-11 09:26

Latest Comments

« First ‹ Previous 1 2 3

Anonymous comment on 2017-04-10 21:24

That is another AUR package, and it is currently at 2.5.1-1, which satisfies the dependency.

https://aur.archlinux.org/packages/python-livereload/

I'm not sure what issue you are having, but I can install mkdocs with no issue.

welkie commented on 2017-04-10 20:35

I'm getting the following message when I try to install mkdocs:

warning: cannot resolve "python-livereload>=2.5.1", a dependency of "mkdocs"
:: The following package cannot be upgraded due to unresolvable dependencies:
mkdocs

XavierCLL commented on 2016-04-30 05:08

Hi, the themes bootstrap and bootswatch should not be dependences, change it to optdepends

davidmcinnis commented on 2016-02-10 04:03

Got it. Thanks!

-Dave

Anonymous comment on 2016-02-05 20:30

@davidmcinnis Could you please read the comment immediately before yours?

Anonymous comment on 2016-01-09 16:38

@daurnimator Putting the depends in the package function is explicitly allowed by the PKGBUILD specification [1]. As such, it works just fine with makepkg and makechrootpkg. If your aur helper tool isn't respecting the PKGBUILD specification, you should file a bug with them.

[1]: https://www.archlinux.org/pacman/PKGBUILD.5.html#_package_splitting

daurnimator commented on 2016-01-08 02:57

`depends` should be at the top level; otherwise aur-helpers fail.

Anonymous comment on 2015-07-11 03:23

@kmacleod It isn't in the upstream sources; I generated it myself. Because mkdocs uses click, it was easy to do.

http://click.pocoo.org/4/bashcomplete/

I used those instructions to generate a completion file and I uploaded it to the AUR with the PKGBUILD.

https://aur4.archlinux.org/cgit/aur.git/tree/mkdocs.bash_completion?h=mkdocs

Cloning this package or downloading a snapshot both include the file. What is the problem you are seeing?

kmacleod commented on 2015-07-10 20:59

mkdocs.bash_completion isn't availabe in the sources.