Package Details: mkdocs 1.0.4-1

Git Clone URL: https://aur.archlinux.org/mkdocs.git (read-only, click to copy)
Package Base: mkdocs
Description: Project documentation with Markdown.
Upstream URL: http://www.mkdocs.org
Licenses: BSD
Submitter: None
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 17
Popularity: 0.022288
First Submitted: 2015-06-11 18:21
Last Updated: 2018-10-11 09:26

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

dcelasun commented on 2017-06-13 20:36

@carlwgeorge: Thanks, but I'm not looking for an AUR helper that seemingly fits a specification that only you are aware of.

_Especially_ since you think the current behaviour of depends/makedepends is a bug (which, literally no one else [0] seem to think so) and your only "proof" is some unnamed TU who might or might not have told you something that is or isn't relevant.

So thanks, I'll pass.

[0] https://www.google.com/search?q=pkgbuild+depends+makedepends+bug+site%3Aarchlinux.org

P.S: Sorry for the snark, but it really gets on my nerves when people dismiss UX concerns on religious arguments and appeals to purity.

Anonymous comment on 2017-06-13 19:12

@dcelasun I found out that pacaur works fine to build this package. Like I said before, switch to an AUR helper that respects the specification.

Anonymous comment on 2017-06-04 02:45

> warning: cannot resolve "python-livereload>=2.5.1", a dependency of "mkdocs"

If you see this warning, then you are using an AUR helper that doesn't properly handle the depends array being in the package function. I suggest switching to a different AUR helper. For example, pacaur cleanly builds this PKGBUILD.

Anonymous comment on 2017-06-04 02:42

@dcelasun

https://wiki.archlinux.org/index.php/PKGBUILD#depends

"An array of packages that must be installed before the software can be run."

https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

"An array of packages that are only required to build the software."

It's not my understanding, it's the literal definition. This definition is not unique to Arch, it's the same for packaging RPMs (my $dayjob) and Debian packages.

I never filed a but because an Arch Trusted User was the one who told me about it. I can't find a bug report for it, but I'll ask that TU if it was ever filed or why it was never fixed, perhaps he can shed some light on the situation.

I'm not changing the PKGBUILD, so you can stop wasting your time giving me attitude. Your time would be much better spent finding an AUR helper that works, or filing a bug with your current AUR helper. It seems the core problem is that your AUR helper isn't looking ahead to see that one of the depends is also an AUR package, and must be built first.

dcelasun commented on 2017-06-03 08:50

@carlwgeorge:

> Those tools should respect the PKGBUILD specification.

> but there is a bug in makepkg where top level depends are installed at build time.

If you are convinced your understanding of the PKGBUILD spec is correct, despite what *everyone* else (including the devs) are doing, surely you have reported this "bug" and can share a link with us, right?

Anonymous comment on 2017-06-03 07:43

@dcelasun

> Since this is not a split package, I think depends() should be on the top level.

Being a split package is not a prerequisite of putting the depends array in the package function.

> all you are doing is causing unnecessary problems for certain AUR helpers

I'm not responsible for bugs in AUR helpers. Those tools should respect the PKGBUILD specification.

> with exactly zero gain.

You are making a faulty assumption that there is no gain. There is a difference between build requirements and run time requirements. You might think that this is covered in a PKGBUILD by having separate makedepends and depends arrays, but there is a bug in makepkg where top level depends are installed at build time. Moving the depends array to the package function actually makes the depends work as intended. This is the more technically correct solution, and benefits anyone who builds packages on separate systems from where they install them. I know you are going to point out that for people using AUR helpers the build system is also the installation system, but frankly that is irrelevant. If an AUR helper is not correctly following the specification then you should use a different AUR helper.

> Additionally, you are violating the PKGBUILD spec [0]: "All packages required to make the package are required to be specified in the global depends and makedepends arrays."

No, I'm not. python-livereload is not required to build mkdocs.

dcelasun commented on 2017-05-31 10:32

@carlwgeorge: Since this is not a split package, I think depends() should be on the top level. I've read the comments below, but all you are doing is causing unnecessary problems for certain AUR helpers with exactly zero gain.

Additionally, you are violating the PKGBUILD spec [0]: "All packages required to make the package are required to be specified in the global depends and makedepends arrays."

[0] https://www.archlinux.org/pacman/PKGBUILD.5.html#_package_splitting

madnight commented on 2017-05-25 19:25

same issue as welkie over here and same solution

i think that yaourt cannot resolve packages deps that are not in the offical arch repos and only available via aur, like python-livereload

Anonymous comment on 2017-04-12 17:46

Both python-livereload and mkdocs build with makepkg and install with pacman. Anything outside of that is outside of my control. I suggest you report the issue to yaourt. It wouldn't be the first time that tool caused unnecessary build problems.

welkie commented on 2017-04-11 23:01

I continue to have the problem. I try to use yaourt to install mkdocs and I get:
warning: cannot resolve "python-livereload>=2.5.1", a dependency of "mkdocs"

I ended up having to override the default behaviour of Arch Linux and use pip to manage the packages. I added the directory where pip package binaries go when installed with "--user" ($HOME/.local/bin) and I installed mkdocs with "pip install --user mkdocs".

I did manually change my mirrors to include only those in the US and Canada with that mirror list generator tool. Do you think that may be related?

______

UPDATE:

I was able to use yaourt to install mkdocs. I first manually installed python-livereload and that succeeded. Then I used "yaourt -S mkdocs" and it succeeded finally. I have no idea why it wasn't able to automatically install the python-livereload dependency.