Package Details: mkdocs 1.1.2-2

Git Clone URL: https://aur.archlinux.org/mkdocs.git (read-only, click to copy)
Package Base: mkdocs
Description: Project documentation with Markdown.
Upstream URL: http://www.mkdocs.org
Keywords: wiki
Licenses: BSD
Conflicts: python-mkdocs
Provides: mkdocs
Submitter: None
Maintainer: AlphaJack
Last Packager: AlphaJack
Votes: 21
Popularity: 1.80
First Submitted: 2015-06-11 18:21
Last Updated: 2021-06-09 20:08

Pinned Comments

AlphaJack commented on 2021-06-10 21:12

Please migrate to the python-mkdocs package, mkdocs will be removed soon

Latest Comments

1 2 3 4 5 Next › Last »

ainola commented on 2021-06-11 22:32

Hi, AlphaJack:

The name "mkdocs" appears to be correct in accordance to the rules on naming Python packages [1]. As this is a standalone program and not a library closely related to the Python ecosystem, it sounds to me like it should remain as is and that python-mkdocs should instead be merged into this package. Indeed, looking through the "getting started" guide on mkdocs' website suggests that the only interaction with mkdocs is as a utility, much like Hugo. Is this correct?

I see that there are many "modules" for mkdoc that have a python- prefix as well; I would also argue that they should simply be "mkdoc-foo" rather than "python-mkdoc-foo" as, again, there's no real relationship to the Python ecosystem.

Am I missing something?

[1] https://wiki.archlinux.org/title/Python_package_guidelines#Package_naming

AlphaJack commented on 2021-06-10 21:12

Please migrate to the python-mkdocs package, mkdocs will be removed soon

alan1world commented on 2021-03-09 15:20

Sadly now my fix won't work. mkdocs has a requirement for nltk buried in it and the requirement is for <3.5. Arch is now on 3.5.3, meaning there are two prerequisites that cannot be met.

Is there a way a package can install into a venv virtual environment?

dcelasun commented on 2021-02-19 00:10

I could patch it here but it's better if they update it upstream.

alan1world commented on 2021-02-19 00:08

Brief initial test indicates that the current version of mkdoc is compatible with lunr-0.5.9, it's just blocked by a rigid requirement.

Changing the requirements line in setup.py is sufficent.

Installed into a venv environment with mkdocs-1.1.2 and lunr-0.5.9:

'lunr[languages]==0.5.8' to 'lunr[languages]>=0.5.8'

AlphaJack commented on 2021-02-16 22:04

A workaround is downgrading python-lunr:

git clone https://aur.archlinux.org/python-lunr.git
git checkout 74a34b4f2c0520babc3c8b2ba72112c90cde1347
makepkg -si

@dcelasun https://github.com/mkdocs/mkdocs/issues/2306

dcelasun commented on 2021-01-29 11:20

python-lunr is now at 0.5.9 so we'll have to wait for an update to mkdocs I think.

hiddeco commented on 2021-01-29 11:04

Broken again, python-lunr is now expected to be 0.5.8:

...
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 570, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'lunr[languages]==0.5.8' distribution was not found and is required by mkdocs

Dirk commented on 2020-07-20 05:43

Thanks, that fix did it. It works now!

dcelasun commented on 2020-07-18 21:32

@dsohler I pushed a fix for python-lunr. Please update that package and try again.