Package Details: mixxx_beta-git r6722-1

Git Clone URL: https://aur.archlinux.org/mixxx_beta-git.git (read-only)
Package Base: mixxx_beta-git
Description: Digital DJ mixing software. 2.3 (beta) branch.
Upstream URL: http://www.mixxx.org/
Keywords: dj mix mp3 pro-audio
Licenses: GPL2
Groups: pro-audio
Provides: mixxx
Submitter: Gimmeapill
Maintainer: Gimmeapill
Last Packager: Gimmeapill
Votes: 0
Popularity: 0.000000
First Submitted: 2018-11-04 18:17
Last Updated: 2019-08-13 06:27

Latest Comments

AndyArch commented on 2019-08-19 19:08

With a downgrade to scons-3.0.4-1 it can be compiled

Gimmeapill commented on 2019-08-15 19:18

Yes, I can confirm, but this looks more like an upstream issue: ui_dlgcontrollerlearning.h is just missing...

AndyArch commented on 2019-08-15 15:09

can not compile! [code] In Datei, eingebunden von src/controllers/dlgcontrollerlearning.cpp:12: src/controllers/dlgcontrollerlearning.h:16:10: schwerwiegender Fehler: controllers/ui_dlgcontrollerlearning.h: Datei oder Verzeichnis nicht gefunden 16 | #include "controllers/ui_dlgcontrollerlearning.h" | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Kompilierung beendet. scons: [lin64_build/controllers/dlgcontrollerlearning.o] Error 1 In Datei, eingebunden von src/controllers/dlgprefcontroller.h:18, von src/controllers/dlgprefcontroller.cpp:16: src/controllers/dlgcontrollerlearning.h:16:10: schwerwiegender Fehler: controllers/ui_dlgcontrollerlearning.h: Datei oder Verzeichnis nicht gefunden 16 | #include "controllers/ui_dlgcontrollerlearning.h" | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Kompilierung beendet. scons: [lin64_build/controllers/dlgprefcontroller.o] Error 1 In Datei, eingebunden von src/controllers/dlgprefcontrollers.cpp:3: src/controllers/dlgprefcontrollers.h:8:10: schwerwiegender Fehler: controllers/ui_dlgprefcontrollersdlg.h: Datei oder Verzeichnis nicht gefunden 8 | #include "controllers/ui_dlgprefcontrollersdlg.h" | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Kompilierung beendet. scons: ** [lin64_build/controllers/dlgprefcontrollers.o] Error 1 src/controllers/delegates/midioptionsdelegate.cpp: In Elementfunktion »virtual QString MidiOptionsDelegate::displayText(const QVariant&, const QLocale&) const«: src/controllers/delegates/midioptionsdelegate.cpp:53:59: Warnung: »T qVariantValue(const QVariant&) [with T = MidiOptions]« ist veraltet [-Wdeprecated-declarations] 53 | MidiOptions options = qVariantValue<MidiOptions>(value); | ^ In Datei, eingebunden von /usr/include/qt/QtCore/qlocale.h:43, von /usr/include/qt/QtCore/qtextstream.h:46, von /usr/include/qt/QtCore/qdebug.h:49, von /usr/include/qt/QtCore/QtDebug:1, von src/controllers/delegates/midioptionsdelegate.cpp:1: /usr/include/qt/QtCore/qvariant.h:877:24: Anmerkung: hier deklariert 877 | inline QT_DEPRECATED T qVariantValue(const QVariant &variant) | ^~~~~~~~~~~~~ src/controllers/delegates/midioptionsdelegate.cpp:53:59: Warnung: »T qVariantValue(const QVariant&) [with T = MidiOptions]« ist veraltet [-Wdeprecated-declarations] 53 | MidiOptions options = qVariantValue<MidiOptions>(value); | ^ In Datei, eingebunden von /usr/include/qt/QtCore/qlocale.h:43, von /usr/include/qt/QtCore/qtextstream.h:46, von /usr/include/qt/QtCore/qdebug.h:49, von /usr/include/qt/QtCore/QtDebug:1, von src/controllers/delegates/midioptionsdelegate.cpp:1: /usr/include/qt/QtCore/qvariant.h:877:24: Anmerkung: hier deklariert 877 | inline QT_DEPRECATED T qVariantValue(const QVariant &variant) | ^~~~~~~~~~~~~ src/controllers/delegates/midioptionsdelegate.cpp: In Elementfunktion »virtual void MidiOptionsDelegate::setEditorData(QWidget, const QModelIndex&) const«: src/controllers/delegates/midioptionsdelegate.cpp:67:78: Warnung: »T qVariantValue(const QVariant&) [with T = MidiOptions]« ist veraltet [-Wdeprecated-declarations] 67 | MidiOptions options = qVariantValue<MidiOptions>(index.data(Qt::EditRole)); | ^ In Datei, eingebunden von /usr/include/qt/QtCore/qlocale.h:43, von /usr/include/qt/QtCore/qtextstream.h:46, von /usr/include/qt/QtCore/qdebug.h:49, von /usr/include/qt/QtCore/QtDebug:1, von src/controllers/delegates/midioptionsdelegate.cpp:1: /usr/include/qt/QtCore/qvariant.h:877:24: Anmerkung: hier deklariert 877 | inline QT_DEPRECATED T qVariantValue(const QVariant &variant) | ^~~~~~~~~~~~~ src/controllers/delegates/midioptionsdelegate.cpp:67:78: Warnung: »T qVariantValue(const QVariant&) [with T = MidiOptions]« ist veraltet [-Wdeprecated-declarations] 67 | MidiOptions options = qVariantValue<MidiOptions>(index.data(Qt::EditRole)); | ^ In Datei, eingebunden von /usr/include/qt/QtCore/qlocale.h:43, von /usr/include/qt/QtCore/qtextstream.h:46, von /usr/include/qt/QtCore/qdebug.h:49, von /usr/include/qt/QtCore/QtDebug:1, von src/controllers/delegates/midioptionsdelegate.cpp:1: /usr/include/qt/QtCore/qvariant.h:877:24: Anmerkung: hier deklariert 877 | inline QT_DEPRECATED T qVariantValue(const QVariant &variant) | ^~~~~~~~~~~~~ scons: building terminated because of errors. ==> FEHLER: Ein Fehler geschah in build(). Breche ab... :: Unable to build mixxx_beta-git - makepkg exited with code: 4 [/code]

Gimmeapill commented on 2019-08-13 06:30

I needed to add explicitly soundtouch, it should build now (I still have to revisit both mixxx pkbuilds in more details).

Gimmeapill commented on 2019-08-13 06:20

@PedroHLC: Thanks for the heads up, I'll look into it very shortly

PedroHLC commented on 2019-08-12 21:54

Building from a clean chroot I get:

Checking for soundtouch (2.0.0 or higher)...    no
ERROR:root:Unmet dependency: No module named 'features'

And ends with:

ERROR:root:Build had unmet dependencies. Exiting.
==> ERROR: A failure occurred in build().

Configure shows others "no" to some checks, but they don't throw any error message.