Package Details: miniconda3 4.10.3-1

Git Clone URL: https://aur.archlinux.org/miniconda3.git (read-only, click to copy)
Package Base: miniconda3
Description: Mini version of Anaconda Python distribution.
Upstream URL: https://conda.io/en/latest/miniconda.html
Keywords: anaconda conda python
Licenses: custom
Submitter: jadelord
Maintainer: Ta180m
Last Packager: Ta180m
Votes: 28
Popularity: 1.59
First Submitted: 2018-06-02 04:06
Last Updated: 2021-09-04 16:22

Dependencies (0)

Required by (1)

Sources (2)

Pinned Comments

jadelord commented on 2021-02-05 09:50

I have packaged micromamba in AUR. Try it if you are looking for a lightweight, barebones alternative to miniconda.

EDIT: I will disown this package, and anyone interested may adopt this.

Latest Comments

1 2 3 4 Next › Last »

kearneyBack commented on 2021-09-17 12:21

Thank you for friendly reply. Sometimes we will install Android Studio, Eclipse in /opt/appname. In default design privilege, user do not have write access to it. It will cause problems when update. In Eclipse example, if use sudo, more wired things happen. Thankfully that not happen with miniconda3.

Ta180m commented on 2021-09-16 23:20

That sounds like it would be a security issue. Users shouldn't randomly be able to write to system files like /opt/miniconda3.

kearneyBack commented on 2021-09-14 10:17

Hello, everyone. I try to conda install -c conda-forge jupyterlab but I got this

EnvironmentNotWritableError: The current user does not have write permissions to the target environment.
  environment location: /opt/miniconda3
  uid: 1000
  gid: 1000

then I add sudo then it work. why not just give the user higher privilege to this package(/opt/miniconda3)? For safety or something else?

kearneyBack commented on 2021-09-03 12:36

From the new PKGBUILD's git diff, I see the versio and sha256sums changed. But as jadelord said, he or she will disown this pkg.The Maintainer still is Ashwin Vishnu <ashwinvis+arch At protonmail DoT cOm>. But from this web page, it writes Maintainer: Ta180m. So it is a manner to keep the Ta180m's position or just something else?

OvelixMax commented on 2021-02-16 06:00

@jadelord, I didn't update conda package in the base environment. I need to use the makepkg method posted by @JcNils and still complains, so, had to:


yay -R miniconda3
sudo rm -rf /opt/miniconda3

and then,


makepkg -sric 

jadelord commented on 2021-02-13 17:49

@OvelixMax, did you ever manually update the conda package in the base environment. Doing so without using package manager might have led to conflicts. Try installing using makepkg and if it still complains, you need to do a clean reinstallation.

OvelixMax commented on 2021-02-12 16:42

Archlinux user here. I can't update miniconda 4.9.2 with python 3.9 using yay.

error: failed to commit transaction (conflicting files)
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/PKG-INFO exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/SOURCES.txt exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/dependency_links.txt exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/entry_points.txt exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/not-zip-safe exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/requires.txt exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda-4.9.2-py3.8.egg-info/top_level.txt exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/__pycache__/asyncio.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/__pycache__/auto.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/__pycache__/cli.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/__pycache__/std.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/__pycache__/utils.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/asyncio.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/auto.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/cli.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/__init__.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/__pycache__/__init__.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/__pycache__/concurrent.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/__pycache__/itertools.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/concurrent.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/contrib/itertools.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/std.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/_vendor/tqdm/utils.py exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/cli/__pycache__/main_compare.cpython-38.pyc exists in filesystem
miniconda3: /opt/miniconda3/lib/python3.8/site-packages/conda/cli/main_compare.py exists in filesystem
Errors occurred, no packages were upgraded.

jadelord commented on 2021-02-05 09:50

I have packaged micromamba in AUR. Try it if you are looking for a lightweight, barebones alternative to miniconda.

EDIT: I will disown this package, and anyone interested may adopt this.

prometheus commented on 2021-01-11 20:04

Is this package really out of date?

JcNils commented on 2020-06-24 16:34

Thank you all the makepkg works

I did it like this.

yay -G miniconda3
cd ./miniconda3
makepkg -sric
sudo ln -s /opt/miniconda3/etc/profile.d/conda.sh /etc/profile.d/conda.sh