Package Details: mini-xfwm4-theme 1.2-1

Git Clone URL: https://aur.archlinux.org/mini-xfwm4-theme.git (read-only, click to copy)
Package Base: mini-xfwm4-theme
Description: Very thin theme for Xfce to keep space for windows.
Upstream URL: http://xfce-look.org/content/show.php?content=154240
Licenses: GPL3
Submitter: cedl38
Maintainer: None
Last Packager: cedl38
Votes: 6
Popularity: 0.000000
First Submitted: 2012-12-19 02:26
Last Updated: 2015-06-14 22:40

Latest Comments

dreieck commented on 2021-04-26 13:09

I fixed the PKGBUILD, but somehow cannot upload to the AUR currently ...

So, here is the PKGBUILD:

# Contributor: Ced <cedl38@gmail.com>

pkgname=mini-xfwm4-theme
pkgver=1.2
pkgrel=2
pkgdesc="Very thin theme for Xfce to keep space for windows."
arch=('any')
url="shttp://xfce-look.org/content/show.php?content=154240"
license=('GPL3')
depends=('xfwm4>=4.8')
optdepends=('xfce4-notifyd>=0.2')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cedl38/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('a3b768c857d1ce2324843263f79fd0b7e81767b4506d80d0b68e57811a81ef4d')

package() {
  cd $srcdir/$pkgname'-'$pkgver
  install -d -m755 $pkgdir/usr/share/themes
  cp -r ${pkgname%%-*}* $pkgdir/usr/share/themes || return 1
}

I disown now so that anyone who wants can adopt and upload the PKGBUILD.

micwoj92 commented on 2021-03-16 09:58

Homepage needs to be https.

dreieck commented on 2020-12-20 11:24

package()-function is missing:

==> ERROR: Missing package() function in <...>/aur-mini-xfwm4-theme/./PKGBUILD
==> ERROR: Makepkg was unable to build mini-xfwm4-theme.

Thanks for maintaining!

cedl38 commented on 2012-12-20 09:24

1.0-2 : add missing sources !