Package Details: mingw-w64-rust-bin 1.37.0-2

Git Clone URL: https://aur.archlinux.org/mingw-w64-rust-bin.git (read-only)
Package Base: mingw-w64-rust-bin
Description: Systems programming language focused on safety, speed and concurrency (PLEASE READ COMMENTS FIRST) (official build, mingw-w64)
Upstream URL: https://www.rust-lang.org
Keywords: mingw-w64 rust
Licenses: custom, MIT, Apache
Conflicts: mingw-w64-rust
Provides: mingw-w64-rust=1.37.0
Submitter: pingplug
Maintainer: pingplug
Last Packager: pingplug
Votes: 4
Popularity: 0.016866
First Submitted: 2018-02-13 16:04
Last Updated: 2019-08-21 02:23

Pinned Comments

pingplug commented on 2018-09-24 05:33

  1. rust will change source package (mostly cargo) without changing file name during minor version update. If the source failed to pass sha256sum check, remove it and try again. If it fails again, please flag this package out-of-date.
  2. Exception handling will be disabled when using sjlj version of GCC (i686-w64-mingw32 toolchain in mingw-w64-gcc).
  3. to use this, you should add /opt/rust/bin to PATH, and set CARGO_HOME to /opt/rust/cargo.

Latest Comments

marmistrz commented on 2019-07-25 11:03

@mati865, I've already added it to the wiki. The command is for rustup, but it can be easily modified to work with this package. You may also need libmsvcrt.a

mati865 commented on 2019-07-25 10:41

mingw-w64-rust-bin can not build executable with 6.0+ version of mingw-w64-crt, but library building works (for example mingw-w64-librsvg).

This can be fixed by replacing Rust shipped crt2.o and dllcrt2.o with the system ones.

marmistrz commented on 2019-07-18 15:15

Please add to the pinned comment the information that in order to use the package for cross compiling, one has to either (a) add /opt/rust/bin to PATH or (b) add /opt/rust/lib to LD_LIBRARY_PATH

EDIT: (b) is not true. Is there any way of using the cross target with system-wide cargo (without changing PATH)?

JJK commented on 2019-05-20 08:38

Is this package still being maintained? The issue pointed out by lantw44 still exists.

lantw44 commented on 2018-09-29 04:35

It seems that the file cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz was changed ...

$ makepkg
...
==> Validating source files with sha256sums...
    cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz ... FAILED
    cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz.asc ... Skipped
    rustc-1.29.1-x86_64-unknown-linux-gnu.tar.gz ... Passed
    rustc-1.29.1-x86_64-unknown-linux-gnu.tar.gz.asc ... Skipped
    rust-std-1.29.1-x86_64-unknown-linux-gnu.tar.gz ... Passed
    rust-std-1.29.1-x86_64-unknown-linux-gnu.tar.gz.asc ... Skipped
    rust-std-1.29.1-i686-pc-windows-gnu.tar.gz ... Passed
    rust-std-1.29.1-i686-pc-windows-gnu.tar.gz.asc ... Skipped
    rust-std-1.29.1-x86_64-pc-windows-gnu.tar.gz ... Passed
    rust-std-1.29.1-x86_64-pc-windows-gnu.tar.gz.asc ... Skipped
==> ERROR: One or more files did not pass the validity check!
$ ls -l cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz 
-rw-r--r-- 1 testuser wheel 7386706 Sep 29 03:58 cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz
$ sha256sum cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz 
b6012ef67923b67b9b558628cc41dd90a688742bf23e9b46ad8839d898f1b0b1  cargo-0.30.0-x86_64-unknown-linux-gnu.tar.gz

pingplug commented on 2018-09-25 01:35

remove version check for MinGW now, but you should read the pinned comment first before installing this package

adsun commented on 2018-09-24 20:34

This still fails to install due to the mingw-w64-crt version required below 6.0.0, not including 6.0.0

pingplug commented on 2018-09-24 05:33

  1. rust will change source package (mostly cargo) without changing file name during minor version update. If the source failed to pass sha256sum check, remove it and try again. If it fails again, please flag this package out-of-date.
  2. Exception handling will be disabled when using sjlj version of GCC (i686-w64-mingw32 toolchain in mingw-w64-gcc).
  3. to use this, you should add /opt/rust/bin to PATH, and set CARGO_HOME to /opt/rust/cargo.

lantw44 commented on 2018-09-23 18:12

The dependency is broken again because mingw-w64-crt has been updated to 6.0.0 ...

dontub commented on 2018-06-14 06:56

Do you plan to release a version that is compatible with mingw-w64-crt 5.0.4?