Package Details: mingw-w64-qt5-base 5.15.2+kde+r172-1

Git Clone URL: (read-only, click to copy)
Package Base: mingw-w64-qt5-base
Description: A cross-platform application and UI framework, native OpenGL backend (mingw-w64)
Upstream URL:
Licenses: custom, GPL3, LGPL3, FDL
Groups: mingw-w64-qt5
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 19
Popularity: 0.000035
First Submitted: 2016-08-30 21:28
Last Updated: 2021-04-14 09:51

Sources (32)

Pinned Comments

Martchus commented on 2021-04-14 10:08

I've been updating this package and some further modules to use patches from KDE's fork. This is in accordance with the native Qt packages. As far as I know KDE's fork is not tagging releases. However, I will not pick up every single new commit on their branch but only update the package when it is worth it. Only flag the package as out-of-date if there are patches on their branch which are generally very important.

Martchus commented on 2020-09-13 11:42

Notes regarding 5.15.1 update

  • With this update I finally splitted all static libraries from further Qt repositories into their own packages as well. So now there's not only mingw-w64-qt5-base-static but also mingw-w64-qt5-svg-static, mingw-w64-qt5-declarative-static and so on. The static version is still sharing files with the shared version and as such depends on the shared packages. However, this change allows to avoid building all the static libraries if only shared libraries are required. If you've so far used static libraries from further Qt modules be sure to install the additional *-static packages.
  • Otherwise there were not much build system changes on the Qt side so I don't think this update broke much.
  • As stated in the sticky comment I'm thinking about Qt 6 packaging but this also means I'm not going to take much effort to address any outstanding bugs/limitations for the Qt 5 packages anymore (broken ANGLE build, build Qt WebEngine, …).
  • This is the last official release of the 5.x. Let's see whether further updates for the 5.x branch will be made available by the community. If the regular qt5-base packages picks up such commits I could update this package here as well.

Martchus commented on 2018-05-29 08:29

Before upgrading, be sure to remove the old version of the package from your system. Preferably, build the package in a clean chroot using makechrootpkg.

Also, please read the other comments and issues on GitHub for known bugs and limitations.

There also exist a binary repository:,

Martchus commented on 2018-03-11 20:19

@theone74 It is currently not possible to use the MariaDB plugin with the static version of Qt because mariadb-connector-c comes with its own pthread implementation which has conflicting symbols with the pthread library Qt uses. Since some PostgreSQL update the same is true for the PostgreSQL plugin.

So you have to disable the plugin. When using CMake, plugins are not be automatically added so you should not run into the issue by default. When using qmake you need to disable the plugin manually, eg. you can add the following arguments to enable only the plugins which actually work:

CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static


Martchus commented on 2016-07-10 19:47

All my packages are managed at GitHub where you can also contribute directly:

Patches for this package are managed at:
if you like to contribute to patches, read this:

If you would like to contribute, here is a list of known bugs and things needing improvement:

  • The linker library search paths for applications which need to be build for the host architecture aren't set correctly. Hence those paths are currently set manually which is quite hacky. Affected packages are mingw-w64-qt5-declarative and mingw-w64-qt5-tools and (also the apple-darwin versions).
  • Compiling QtAV using the ANGLE version doesn't work. I don't know whether other applications/libs using OpenGL via Qt are also affected but it is very likely.
  • Updating mingw-w64-qt5-webkit to ng version.
  • See also

Also note the comments about the different variants inside the PKGBUILD itself.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Martchus commented on 2017-06-08 20:06

Qt 5.9.0 is there :-)
See my previous comment about openssl. Additionally, this is using pcre2 now. The location module now always needs ANGLE at build time (for some plugin), otherwise the build fails. Since problems of patch 0023-Allow-usage-of-static-version-with-CMake.patch still haven't been resolved yet you might want to build without it if you don't need to use the static version with CMake.

Users of my binary repo must execute the following commands after upgrading all Qt modules to be able to use the static version with CMake:
find /usr/{i686,x86_64}-w64-mingw32/lib/cmake -iname 'StaticQt5*Config.cmake' -exec sed -i 's/Qt5::\(.*\)Private/StaticQt5::\1Private/g' {} \;
find /usr/{i686,x86_64}-w64-mingw32/lib -iname 'Qt5*.static.prl' -exec sed -i 's/-lpcre16/-lversion -lpcre2-16/g' {} \;
find /usr/{i686,x86_64}-w64-mingw32/lib/qt/mkspecs/mingw-w64-g++ -iname '*.conf' -exec sed -i 's/-lpcre16/-lversion -lpcre2-16/g' {} \;
(I just don't want to keep my server busy for hours with rebuilding if executing 3 commands is sufficient.)

Martchus commented on 2017-06-07 10:32

@xantares As far as I'm concerned there is no such patch. The regular qt5-base still uses the old openssl. I follow this approach for Qt 5.9.0 and it seems to work fine. Hence I already provide mingw-w64-openssl-1.0 which doesn't conflict with mingw-w64-openssl. So the error should be gone when I push 5.9 here. Till then, don't update to openssl to 1.1. Or use the packages for 5.9 which are already available in my PKGBUILDs repo.

xantares commented on 2017-06-07 06:35

it doesnt build because of openssl>= 1.1, is there a similar patch for what's available for qt4 ?

Martchus commented on 2017-05-01 22:18

Note that this is likely not compatible with the latest version of mingw-w64-openssl so I wouldn't recommend updating it so far. Maybe a package mingw-w64-openssl-1.0 like the regular openssl-1.0 is required.

Martchus commented on 2017-02-07 00:39

Current version is on 'update/qt5' branch of my PKGBUILDs repository:

I haven't pushed it yet because there are still some outstanding problems with the static variant. One is that dependencies are not correctly written in prl files. However, those files are used by the CMake modules which hence not work correctly (specifically the dependency cycle between freetype2 and harfbuzz is messed). Not sure how to fix this. Also building qt5-tools failed last time I tried to build it due to missing dependencies required by Qt DBus. This should be fixed now, but I'll have to verify first.

Martchus commented on 2017-01-25 18:48

Updating this to 5.8.0 will take some time. Patches are rebased, however the new config system doesn't allow to configure Qt in the same way as it was possible in previous versions (can not use iconv and pkg-config for instance).

dviktor commented on 2017-01-01 22:07

I have cleared ~/.cache/pacaur completely and after that all compiled fine!

Martchus commented on 2016-12-31 14:01

@dviktor Seems like something is completely messed in your build. Have you tried to discard it completely and rebuild from the scratch (preferably in clean chroot, at you have to uninstall previous version of the package)?

It would be also helpful to have English error messages. I assume the header file can not be found? Actually it is quite strange that those header files are included when building the Windows version.

dviktor commented on 2016-12-31 10:08

Some errors:

../../../../qtbase-opensource-src-5.7.1/config.tests/unix/getifaddrs/getifaddrs.cpp:48:24: фатальная ошибка: sys/socket.h: Нет такого файла или каталога
#include <sys/socket.h>

../../../../qtbase-opensource-src-5.7.1/config.tests/unix/ppoll/ppoll.cpp:41:18: фатальная ошибка: poll.h: Нет такого файла или каталога
#include <poll.h>

../../../../qtbase-opensource-src-5.7.1/config.tests/unix/openvg/openvg.cpp:46:23: фатальная ошибка: VG/openvg.h: Нет такого файла или каталога
#include <VG/openvg.h>

../../../../qtbase-opensource-src-5.7.1/config.tests/unix/alsa/alsatest.cpp:40:28: фатальная ошибка: alsa/asoundlib.h: Нет такого файла или каталога
#include <alsa/asoundlib.h>

i686-w64-mingw32-g++ -g -shared -Wl,-subsystem,windows -Wl,--out-implib,/home/viktor/.cache/pacaur/mingw-w64-qt5-base/src/build-i686-w64-mingw32/lib/libQt5Gui.dll.a -o ../../lib/Qt5Gui.dll object_script.Qt5Gui.Release -lcomdlg32 -loleaut32 -limm32 -luuid -ladvapi32 -ljpeg -lpng -L/usr/i686-w64-mingw32/lib -lharfbuzz -lglib-2.0 -lws2_32 -lole32 -lwinmm -lshlwapi -lpcre -lintl -liconv -lgraphite2 -lfreetype -lbz2 -lglu32 -lopengl32 -lgdi32 -luser32 -L/home/viktor/.cache/pacaur/mingw-w64-qt5-base/src/build-i686-w64-mingw32/lib /usr/i686-w64-mingw32/lib/libQt5Core.dll.a -lharfbuzz -lz -lpng16
./.obj/release/qtextdocument_p.o: In function `ZN16QFragmentMapDataI17QTextFragmentDataE14createFragmentEv':
/home/viktor/.cache/pacaur/mingw-w64-qt5-base/src/qtbase-opensource-src-5.7.1/include/QtGui/5.7.1/QtGui/private/../../../../../src/gui/text/qfragmentmap_p.h:258: undefined reference to `_imp___Z26qCalculateGrowingBlockSizejjj'
./.obj/release/qtextdocument_p.o: In function `ZN16QFragmentMapDataI14QTextBlockDataE14createFragmentEv':
/home/viktor/.cache/pacaur/mingw-w64-qt5-base/src/qtbase-opensource-src-5.7.1/include/QtGui/5.7.1/QtGui/private/../../../../../src/gui/text/qfragmentmap_p.h:258: undefined reference to `_imp___Z26qCalculateGrowingBlockSizejjj'
collect2: ошибка: выполнение ld завершилось с кодом возврата 1

dviktor commented on 2016-12-31 08:55

Still can not update to the 5.7.1... A lot of compile errors (including missing headers pulseaudio.h and linker issues), I'll try to post some of them later...